summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author007exe2019-11-02 08:19:29 +0300
committer007exe2019-11-02 08:19:29 +0300
commit693322536234c433d0b4a4ea106ac594ec82e34e (patch)
tree985aded0c9c7f595d54b936e354b378dd646aa66
parentab1c6649fe339d5213fa50c4063f0dd5b6fa0b97 (diff)
downloadaur-693322536234c433d0b4a4ea106ac594ec82e34e.tar.gz
fix
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD15
2 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 911f3fedb9c6..806858d30e3f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = openxray-git
pkgdesc = Unofficial X-Ray Engine Linux port by OpenXRay team (Originally developed by GSC Game World)
- pkgver = 1.6.02_b551.ec0314c03
+ pkgver = 1.6.02_770202c82
pkgrel = 1
url = https://github.com/OpenXRay/xray-16
install = info.install
@@ -28,7 +28,8 @@ pkgbase = openxray-git
depends = lzop
depends = libjpeg-turbo
conflicts = openxray
- source = xray-16::git+https://github.com/OpenXRay/xray-16.git#commit=ec0314c0
+ conflicts = openxray-dev
+ source = xray-16::git+https://github.com/OpenXRay/xray-16.git#branch=xd_dev
md5sums = SKIP
pkgname = openxray-git
diff --git a/PKGBUILD b/PKGBUILD
index ce9b1e8fd39c..8e49bed6678d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
+# Contributor: chip_exe
+# https://aur.archlinux.org/packages/openxray-git/
+# <openxray@yahoo.com>
pkgname=openxray-git
-_commit=ec0314c0
-_build=551
-pkgver=1.6.02_b551.ec0314c03
+pkgver=1.6.02_770202c82
pkgrel=1
pkgdesc="Unofficial X-Ray Engine Linux port by OpenXRay team (Originally developed by GSC Game World)"
arch=('x86_64')
@@ -10,15 +11,13 @@ license=('custom:Custom 3-сlause BSD')
install="info.install"
makedepends=(gcc git cmake libglvnd libjpeg6-turbo ncurses pcre2 pcre)
depends=(glew sdl2 openal intel-tbb crypto++ liblockfile freeimage libogg libtheora libvorbis lzo lzop libjpeg-turbo)
-conflicts=(openxray)
-source=(xray-16::git+https://github.com/OpenXRay/xray-16.git#commit=$_commit)
+conflicts=(openxray openxray-dev)
+source=(xray-16::git+https://github.com/OpenXRay/xray-16.git#branch=xd_dev)
md5sums=('SKIP')
pkgver() {
cd "$srcdir/xray-16"
- # OpenXRay versioning is based on AppVeyor build number
- # https://ci.appveyor.com/project/OpenXRay/xray-16
- printf 1.6.02_"b%s.%s" $_build "$(git rev-parse --short HEAD)"
+ printf 1.6.02_"$(git rev-parse --short HEAD)"
}
prepare(){