summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArch Nous2015-06-11 15:51:54 +0300
committerArch Nous2015-06-11 15:51:54 +0300
commit87f8f719961e1edd6fd329050fc5463cd8f3e7b4 (patch)
tree4949fff80866d4504b5f98fefb3314afc23d7930
downloadaur-87f8f719961e1edd6fd329050fc5463cd8f3e7b4.tar.gz
Initial import
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD44
-rw-r--r--opera-116.install29
3 files changed, 98 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cf4ad41b1632
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = opera-116
+ pkgdesc = The fastest browser on earth. Last 11-series version, if you find opera 12 unstable or bloated.
+ pkgver = 11.62_1347
+ pkgrel = 2
+ url = http://www.opera.com/browser/
+ install = opera-116.install
+ arch = i686
+ arch = x86_64
+ license = custom:opera
+ depends = gcc-libs
+ depends = libxt
+ depends = freetype2
+ depends = libxext
+ optdepends = gstreamer0.10-base-plugins: HTML5 Video support
+ optdepends = gstreamer0.10-good: HTML5 Video support
+ provides = opera
+ options = !strip
+ options = !zipman
+ source = http://arc.opera.com/snapshot/linux-freebsd/opera-11.62-1347.i386.linux.tar.xz
+ source = http://people.opera.com/ruario/opera-next-icons_20111107.tar.xz
+ sha256sums = 0d5a8f88453637c5248628cf343e57ef4f130971c7fc65a2b4dcbef2c5ec057d
+ sha256sums = 4040aad19e11c6e32d3603467858bf58dd389b24a4314e7cbb8b86c9c7b689fd
+
+pkgname = opera-116
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8a0de8da8af6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: nous
+
+pkgname=opera-116 # Set to "opera" or "opera-next" if you want to replace either of these
+_bigrelease=11.62
+_buildver=1347
+pkgver=${_bigrelease}_${_buildver}
+pkgrel=2
+pkgdesc="The fastest browser on earth. Last 11-series version, if you find opera 12 unstable or bloated."
+url="http://www.opera.com/browser/"
+depends=('gcc-libs' 'libxt' 'freetype2' 'libxext')
+provides=('opera')
+optdepends=('gstreamer0.10-base-plugins: HTML5 Video support' 'gstreamer0.10-good: HTML5 Video support')
+install=opera-116.install
+options=(!strip !zipman)
+license=('custom:opera')
+arch=('i686' 'x86_64')
+_arch=i386
+[ "$CARCH" = "x86_64" ] && _arch=x86_64
+source=(http://arc.opera.com/snapshot/linux-freebsd/opera-${_bigrelease}-${_buildver}.${_arch}.linux.tar.xz http://people.opera.com/ruario/opera-next-icons_20111107.tar.xz)
+sha256sums=('0d5a8f88453637c5248628cf343e57ef4f130971c7fc65a2b4dcbef2c5ec057d' '4040aad19e11c6e32d3603467858bf58dd389b24a4314e7cbb8b86c9c7b689fd')
+[ "$CARCH" = "x86_64" ] && sha256sums=('e13dba391ba4d76ea6d8f5b9d18cde0f312217c6c28f530f994812756b46bab4' '4040aad19e11c6e32d3603467858bf58dd389b24a4314e7cbb8b86c9c7b689fd')
+
+# Uncomment the following line, if you want your User Agent to include Arch Linux.
+#_opdistro="Arch Linux"
+
+package() {
+ opera-${_bigrelease}-${_buildver}.${_arch}.linux/install --prefix /usr --name ${pkgname} --repackage "${pkgdir}/usr"
+ install -D -m 644 "${pkgdir}/usr/share/${pkgname}/defaults/license.txt" "${pkgdir}/usr/share/licenses/${pkgname}/license.txt"
+
+ # User Opera Next icon set if package name is set to Opera Next
+ if [ "${pkgname}" = "opera-next" ]; then
+ tar -xf opera-next-icons_20111107.tar.xz -C "${pkgdir}"
+ sed -i "s/^\(Product=\)opera$/\1opera-next/" "${pkgdir}/usr/share/opera-next/package-id.ini"
+ fi
+
+ # Insert an Arch User Agent string if set
+ if [ -n "${_opdistro}" ]
+ then
+ mkdir -p "${pkgdir}/usr/share/${pkgname}/custom/defaults"
+ echo "[ISP]" > "${pkgdir}/usr/share/${pkgname}/custom/defaults/operaprefs.ini"
+ echo "Id=${_opdistro}" >> "${pkgdir}/usr/share/${pkgname}/custom/defaults/operaprefs.ini"
+ chmod 644 "${pkgdir}/usr/share/${pkgname}/custom/defaults/operaprefs.ini"
+ fi
+}
diff --git a/opera-116.install b/opera-116.install
new file mode 100644
index 000000000000..385bcb4d0ffc
--- /dev/null
+++ b/opera-116.install
@@ -0,0 +1,29 @@
+available()
+{
+ which "$1" >/dev/null 2>&1
+}
+
+post_install() {
+if available update-mime-database
+then
+ update-mime-database /usr/share/mime >/dev/null
+fi
+
+if available update-desktop-database
+then
+ update-desktop-database -q /usr/share/applications
+fi
+
+if available gtk-update-icon-cache
+then
+ gtk-update-icon-cache -q /usr/share/icons/hicolor
+fi
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}