summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBlackEagle2018-08-08 10:45:06 +0200
committerBlackEagle2018-08-08 10:45:06 +0200
commitfb8fb5beac7a28dc3031ca28232206e923df3921 (patch)
tree1096be7a03d4260d95e2689927c08026d44f16c2
parent536b57c1022ec35db91d49f1d058e267ba88dc8e (diff)
downloadaur-fb8fb5beac7a28dc3031ca28232206e923df3921.tar.gz
opera-developer-ffmpeg-codecs :: 69.0.3493.3-1
Signed-off-by: BlackEagle <ike.devolder@gmail.com>
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD20
-rw-r--r--chromium-compiler-r3.patch182
-rw-r--r--chromium-ffmpeg-clang.patch21
4 files changed, 17 insertions, 217 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fd1f0139fb9d..7d84a7b892da 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Mon Jul 23 13:26:58 UTC 2018
+# Wed Aug 8 08:45:06 UTC 2018
pkgbase = opera-developer-ffmpeg-codecs
pkgdesc = additional support for proprietary codecs for opera-developer
- pkgver = 69.0.3486.0
+ pkgver = 69.0.3493.3
pkgrel = 1
url = https://ffmpeg.org/
arch = x86_64
@@ -16,13 +16,12 @@ pkgbase = opera-developer-ffmpeg-codecs
makedepends = python2
makedepends = xdg-utils
makedepends = ncurses5-compat-libs
+ makedepends = gn-git
depends = glibc
options = !strip
- source = https://commondatastorage.googleapis.com/chromium-browser-official/chromium-69.0.3486.0.tar.xz
- source = chromium-last-commit-position-r1.patch
+ source = https://commondatastorage.googleapis.com/chromium-browser-official/chromium-69.0.3493.3.tar.xz
source = chromium-FORTIFY_SOURCE-r2.patch
- sha512sums = 96bb8aa96400b0a21cd2f2857e76d99e0f22a2b5d73eb2e3115c16562cd0970d04399c3fefa3b86be59ba60814974d295cd303a98f63b4f8ee8ff0f582a77d70
- sha512sums = 8f63366ca998e3ee06a79c6df5b4454707bd9865913ecde2f79fcb49fdd86d291f678b9f21807e4eb61d15497cdbe4a4bdc06637882e708f34f6804453bdfd41
+ sha512sums = 96393f8939fccc8514094f9215496883f416669e61feb45b706610f67ff90672a88f9154fb06e59dec9d363c5e9a072bf1f2ba562dd533345a493664dabcb19e
sha512sums = 2d78092a700788c74b86db636af303fdb63a28ce5b7b0431dd81f6b7ce501e5d0234a6327a1b49bc23e1c1d00ba98fd5334dd07d9a20bb0d81d1a4ca4487a26c
pkgname = opera-developer-ffmpeg-codecs
diff --git a/PKGBUILD b/PKGBUILD
index 2c11c67fb265..ee385ec47a40 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
+# vim:set ft=sh:
# Maintainer: BlackEagle < ike DOT devolder AT gmail DOT com >
pkgname=opera-developer-ffmpeg-codecs
-pkgver=69.0.3486.0
+pkgver=69.0.3493.3
pkgrel=1
pkgdesc="additional support for proprietary codecs for opera-developer"
arch=('x86_64')
@@ -10,16 +11,14 @@ license=('LGPL2.1')
depends=('glibc')
makedepends=(
'gtk3' 'libexif' 'libxss' 'ninja' 'nss' 'pciutils' 'python2'
- 'xdg-utils' 'ncurses5-compat-libs'
+ 'xdg-utils' 'ncurses5-compat-libs' 'gn-git'
)
options=('!strip')
source=(
"https://commondatastorage.googleapis.com/chromium-browser-official/chromium-$pkgver.tar.xz"
- 'chromium-last-commit-position-r1.patch'
'chromium-FORTIFY_SOURCE-r2.patch'
)
-sha512sums=('96bb8aa96400b0a21cd2f2857e76d99e0f22a2b5d73eb2e3115c16562cd0970d04399c3fefa3b86be59ba60814974d295cd303a98f63b4f8ee8ff0f582a77d70'
- '8f63366ca998e3ee06a79c6df5b4454707bd9865913ecde2f79fcb49fdd86d291f678b9f21807e4eb61d15497cdbe4a4bdc06637882e708f34f6804453bdfd41'
+sha512sums=('96393f8939fccc8514094f9215496883f416669e61feb45b706610f67ff90672a88f9154fb06e59dec9d363c5e9a072bf1f2ba562dd533345a493664dabcb19e'
'2d78092a700788c74b86db636af303fdb63a28ce5b7b0431dd81f6b7ce501e5d0234a6327a1b49bc23e1c1d00ba98fd5334dd07d9a20bb0d81d1a4ca4487a26c')
prepare() {
@@ -33,7 +32,6 @@ prepare() {
mkdir "$srcdir/path"
ln -s /usr/bin/python2 "$srcdir/path/python"
- patch -p1 -i "$srcdir/chromium-last-commit-position-r1.patch"
patch -p1 -i "$srcdir/chromium-FORTIFY_SOURCE-r2.patch"
}
@@ -49,8 +47,14 @@ build() {
local args="ffmpeg_branding=\"ChromeOS\" proprietary_codecs=true enable_hevc_demuxing=true use_gnome_keyring=false use_sysroot=false use_gold=false use_allocator=\"none\" linux_use_bundled_binutils=false fatal_linker_warnings=false treat_warnings_as_errors=false enable_nacl=false enable_nacl_nonsfi=false is_clang=false clang_use_chrome_plugins=false is_component_build=true is_debug=false symbol_level=0 use_custom_libcxx=false use_lld=false use_jumbo_build=false"
- python2 tools/gn/bootstrap/bootstrap.py -v -s
- out/Release/gn gen out/Release -v --args="$args" --script-executable=/usr/bin/python2
+ #(
+ #cd third_party/ffmpeg
+ #chromium/scripts/build_ffmpeg.py linux x64 --branding ChromeOS
+ #chromium/scripts/copy_config.sh
+ #chromium/scripts/generate_gn.py
+ #)
+
+ gn gen out/Release -v --args="$args" --script-executable=/usr/bin/python2
ninja -C out/Release -v media/ffmpeg
}
diff --git a/chromium-compiler-r3.patch b/chromium-compiler-r3.patch
deleted file mode 100644
index ca41add408ee..000000000000
--- a/chromium-compiler-r3.patch
+++ /dev/null
@@ -1,182 +0,0 @@
-From cba2fccce163bc549db529c5d6783478de908325 Mon Sep 17 00:00:00 2001
-From: Mike Gilbert <floppym@gentoo.org>
-Date: Wed, 25 Apr 2018 13:22:49 -0400
-Subject: [PATCH] Disable various compiler configs
-
----
- build/config/compiler/BUILD.gn | 68 +++++++++-------------------------
- 1 file changed, 18 insertions(+), 50 deletions(-)
-
-diff --git a/build/config/compiler/BUILD.gn b/build/config/compiler/BUILD.gn
-index 2d82ed5b4e23..23632b156900 100644
---- a/build/config/compiler/BUILD.gn
-+++ b/build/config/compiler/BUILD.gn
-@@ -225,8 +225,6 @@ config("compiler") {
-
- configs += [
- # See the definitions below.
-- ":clang_revision",
-- ":compiler_cpu_abi",
- ":compiler_codegen",
- ]
-
-@@ -488,18 +486,6 @@ config("compiler") {
- }
- }
-
-- if (is_clang && !is_nacl && current_toolchain == host_toolchain &&
-- target_os != "chromeos") {
-- cflags += [
-- # TODO(hans): Remove this once Clang generates better optimized debug info
-- # by default. https://crbug.com/765793
-- "-Xclang",
-- "-mllvm",
-- "-Xclang",
-- "-instcombine-lower-dbg-declare=0",
-- ]
-- }
--
- # Print absolute paths in diagnostics. There is no precedent for doing this
- # on Linux/Mac (GCC doesn't support it), but MSVC does this with /FC and
- # Windows developers rely on it (crbug.com/636109) so only do this on Windows.
-@@ -672,13 +658,6 @@ config("compiler") {
- ldflags += [ "-Wl,--no-rosegment" ]
- }
-
-- # This flag enforces that member pointer base types are complete. It helps
-- # prevent us from running into problems in the Microsoft C++ ABI (see
-- # https://crbug.com/847724).
-- if (is_clang && !is_nacl && target_os != "chromeos" && !use_xcode_clang) {
-- cflags += [ "-fcomplete-member-pointers" ]
-- }
--
- # Pass the same C/C++ flags to the objective C/C++ compiler.
- cflags_objc += cflags_c
- cflags_objcc += cflags_cc
-@@ -1467,10 +1446,6 @@ config("default_warnings") {
- cflags += [
- # TODO(thakis): https://crbug.com/753973
- "-Wno-enum-compare-switch",
--
-- # Ignore warnings about MSVC optimization pragmas.
-- # TODO(thakis): Only for no_chromium_code? http://crbug.com/505314
-- "-Wno-ignored-pragma-optimize",
- ]
- }
- }
-@@ -1512,22 +1487,6 @@ config("chromium_code") {
- "__STDC_FORMAT_MACROS",
- ]
-
-- if (!is_debug && !using_sanitizer &&
-- (!is_linux || !is_clang || is_official_build) &&
-- current_cpu != "s390x" && current_cpu != "s390" &&
-- current_cpu != "ppc64" && current_cpu != "ppc64" &&
-- current_cpu != "mips" && current_cpu != "mips64") {
-- # _FORTIFY_SOURCE isn't really supported by Clang now, see
-- # http://llvm.org/bugs/show_bug.cgi?id=16821.
-- # It seems to work fine with Ubuntu 12 headers though, so use it in
-- # official builds.
-- #
-- # Non-chromium code is not guaranteed to compile cleanly with
-- # _FORTIFY_SOURCE. Also, fortified build may fail when optimizations are
-- # disabled, so only do that for Release build.
-- defines += [ "_FORTIFY_SOURCE=2" ]
-- }
--
- if (is_mac || is_ios) {
- cflags_objc = [ "-Wobjc-missing-property-synthesis" ]
- cflags_objcc = [ "-Wobjc-missing-property-synthesis" ]
-@@ -1857,7 +1816,8 @@ config("default_stack_frames") {
- }
-
- # Default "optimization on" config.
--config("optimize") {
-+config("optimize") { }
-+config("xoptimize") {
- if (is_win) {
- # TODO(thakis): Remove is_clang here, https://crbug.com/598772
- if (is_official_build && full_wpo_on_official && !is_clang) {
-@@ -1891,7 +1851,8 @@ config("optimize") {
- }
-
- # Same config as 'optimize' but without the WPO flag.
--config("optimize_no_wpo") {
-+config("optimize_no_wpo") { }
-+config("xoptimize_no_wpo") {
- if (is_win) {
- # Favor size over speed, /O1 must be before the common flags. The GYP
- # build also specifies /Os and /GF but these are implied by /O1.
-@@ -1914,7 +1875,8 @@ config("optimize_no_wpo") {
- }
-
- # Turn off optimizations.
--config("no_optimize") {
-+config("no_optimize") { }
-+config("xno_optimize") {
- if (is_win) {
- cflags = [
- "/Od", # Disable optimization.
-@@ -1938,7 +1900,8 @@ config("no_optimize") {
- # Turns up the optimization level. On Windows, this implies whole program
- # optimization and link-time code generation which is very expensive and should
- # be used sparingly.
--config("optimize_max") {
-+config("optimize_max") { }
-+config("xoptimize_max") {
- if (is_nacl && is_nacl_irt) {
- # The NaCl IRT is a special case and always wants its own config.
- # Various components do:
-@@ -1985,7 +1948,8 @@ config("optimize_max") {
- #
- # TODO(crbug.com/621335) - rework how all of these configs are related
- # so that we don't need this disclaimer.
--config("optimize_speed") {
-+config("optimize_speed") { }
-+config("xoptimize_speed") {
- if (is_nacl && is_nacl_irt) {
- # The NaCl IRT is a special case and always wants its own config.
- # Various components do:
-@@ -2023,7 +1987,8 @@ config("optimize_speed") {
- }
- }
-
--config("optimize_fuzzing") {
-+config("optimize_fuzzing") { }
-+config("xoptimize_fuzzing") {
- cflags = [ "-O1" ] + common_optimize_on_cflags
- ldflags = common_optimize_on_ldflags
- visibility = [ ":default_optimization" ]
-@@ -2109,7 +2074,8 @@ config("afdo") {
- # configs += [ "//build/config/compiler:symbols" ]
-
- # Full symbols.
--config("symbols") {
-+config("symbols") { }
-+config("xsymbols") {
- if (is_win) {
- if (use_goma || is_clang) {
- # Note that with VC++ this requires is_win_fastlink, enforced elsewhere.
-@@ -2207,7 +2173,8 @@ config("symbols") {
- # Minimal symbols.
- # This config guarantees to hold symbol for stack trace which are shown to user
- # when crash happens in unittests running on buildbot.
--config("minimal_symbols") {
-+config("minimal_symbols") { }
-+config("xminimal_symbols") {
- if (is_win) {
- # Linker symbols for backtraces only.
- cflags = []
-@@ -2238,7 +2205,8 @@ config("minimal_symbols") {
- }
-
- # No symbols.
--config("no_symbols") {
-+config("no_symbols") { }
-+config("xno_symbols") {
- if (!is_win) {
- cflags = [ "-g0" ]
- asmflags = cflags
---
-2.18.0.rc2
-
diff --git a/chromium-ffmpeg-clang.patch b/chromium-ffmpeg-clang.patch
deleted file mode 100644
index 3593d5eec80a..000000000000
--- a/chromium-ffmpeg-clang.patch
+++ /dev/null
@@ -1,21 +0,0 @@
---- a/third_party/ffmpeg/chromium/scripts/build_ffmpeg.py
-+++ b/third_party/ffmpeg/chromium/scripts/build_ffmpeg.py
-@@ -639,18 +639,8 @@
- if 'win' not in target_os:
- configure_flags['Common'].extend([
- '--enable-pic',
-- '--cc=clang',
-- '--cxx=clang++',
-- '--ld=clang',
- ])
-
-- # Clang Linux will use the first 'ld' it finds on the path, which will
-- # typically be the system one, so explicitly configure use of Clang's
-- # ld.lld, to ensure that things like cross-compilation and LTO work.
-- # This does not work for arm64, ia32 and is always used on mac.
-- if target_arch not in ['arm64', 'ia32', 'mipsel'] and target_os != 'mac':
-- configure_flags['Common'].append('--extra-ldflags=-fuse-ld=lld')
--
- # Should be run on Mac, unless we're cross-compiling on Linux.
- if target_os == 'mac':
- if host_os != 'mac' and host_os != 'linux':