summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJean-Francois Chevrette2019-05-05 16:13:08 -0400
committerJean-Francois Chevrette2019-05-05 16:13:08 -0400
commit171ddead7ff12297db16f575cb00972c3c58ab48 (patch)
tree5daba18fa8de6b336a9ed488f84ade29782a3dcc
downloadaur-171ddead7ff12297db16f575cb00972c3c58ab48.tar.gz
initial import
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD16
3 files changed, 32 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8c7672f09e12
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = operator-sdk
+ pkgdesc = YAML templating tool that works on YAML structure instead of text
+ pkgver = 0.7.0
+ pkgrel = 1
+ url = https://github.com/operator-framework/operator-sdk
+ arch = x86_64
+ license = Apache
+ source = https://github.com/operator-framework/operator-sdk/releases/download/v0.7.0/operator-sdk-v0.7.0-x86_64-linux-gnu
+ sha256sums = 3e9056e63e00c8616a4a4d9ed7e1fa0f0b552a4c8673771f397bc76f4756c66b
+
+pkgname = operator-sdk
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..34aece5ef94e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/*.tar.xz
+/pkg
+/src
+/operator-sdk*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..72ab7598b8dc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,16 @@
+# Maintainer: Jean-Francois Chevrette <jfchevrette@gmail.com>
+
+pkgname=operator-sdk
+pkgver=0.7.0
+pkgrel=1
+pkgdesc="YAML templating tool that works on YAML structure instead of text"
+url="https://github.com/operator-framework/operator-sdk"
+license=('Apache')
+arch=('x86_64')
+depends=()
+source=("https://github.com/operator-framework/operator-sdk/releases/download/v${pkgver}/operator-sdk-v${pkgver}-${CARCH}-linux-gnu")
+sha256sums=('3e9056e63e00c8616a4a4d9ed7e1fa0f0b552a4c8673771f397bc76f4756c66b')
+
+package() {
+ install -Dm755 "${srcdir}/operator-sdk-v${pkgver}-${CARCH}64-linux-gnu" "${pkgdir}/usr/bin/operator-sdk"
+}