summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Hansen2016-09-14 20:56:56 -0700
committerMichael Hansen2016-09-14 20:56:56 -0700
commit2c3d36e9603dcec7352abb4049ab4d115c216c2b (patch)
tree53636c47f66f74e1fc31ba1583d4f19210f34366
downloadaur-2c3d36e9603dcec7352abb4049ab4d115c216c2b.tar.gz
Initial commit; opkg 0.3.3
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD34
-rwxr-xr-xautogen.sh128
4 files changed, 188 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..36ea1314edbb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Thu Sep 15 03:56:43 UTC 2016
+pkgbase = opkg
+ pkgdesc = Opkg is a lightweight package management system based upon ipkg
+ pkgver = 0.3.3
+ pkgrel = 1
+ url = https://code.google.com/archive/p/opkg/
+ arch = i386
+ arch = x86_64
+ license = GPL
+ depends = curl
+ depends = libarchive
+ depends = gpgme
+ depends = libsolv
+ source = http://downloads.yoctoproject.org/releases/opkg/opkg-0.3.3.tar.gz
+ source = autogen.sh
+ sha256sums = 19db9e73121a5e4c91fa228b0a6a4c55cc3591056130cfb3c66c30aa32f8d00e
+ sha256sums = 72d2b5491458f0fb5fabaa5bb65482fe1fb256b39cef258029116872ed34dbe2
+
+pkgname = opkg
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ae9b99004d76
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+/src/
+/pkg/
+*.pkg.tar.xz
+*.src.tar.gz
+opkg-*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1a11e1bd0958
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Michael Hansen <zrax0111 gmail com>
+
+pkgname=opkg
+pkgver=0.3.3
+pkgrel=1
+pkgdesc="Opkg is a lightweight package management system based upon ipkg"
+arch=('i386' 'x86_64')
+url="https://code.google.com/archive/p/opkg/"
+license=('GPL')
+depends=('curl' 'libarchive' 'gpgme' 'libsolv')
+source=("http://downloads.yoctoproject.org/releases/${pkgname}/${pkgname}-${pkgver}.tar.gz"
+ 'autogen.sh')
+sha256sums=('19db9e73121a5e4c91fa228b0a6a4c55cc3591056130cfb3c66c30aa32f8d00e'
+ '72d2b5491458f0fb5fabaa5bb65482fe1fb256b39cef258029116872ed34dbe2')
+
+prepare() {
+ # This is stripped out of releases, but the provided configure script
+ # doesn't work out-of-the-box on Arch
+ ln -sf ../autogen.sh "${srcdir}/${pkgname}-${pkgver}/autogen.sh"
+}
+
+build() {
+ cd ${pkgname}-${pkgver}
+
+ ./autogen.sh
+ ./configure --prefix=/usr --with-libsolv
+ make
+}
+
+package() {
+ cd ${pkgname}-${pkgver}
+
+ make DESTDIR="${pkgdir}/" install
+}
diff --git a/autogen.sh b/autogen.sh
new file mode 100755
index 000000000000..333a1512370f
--- /dev/null
+++ b/autogen.sh
@@ -0,0 +1,128 @@
+#!/bin/sh
+
+PACKAGE="opkg"
+
+srcdir=`dirname $0`
+test -z "$srcdir" && srcdir=.
+
+cd "$srcdir"
+DIE=0
+
+if [ \( $# -eq 1 \) -a \( "$1" = "--clean" \) ]; then
+ # Deep clean of all generated files
+ echo "Removing old files (no Makefile around?) ..."
+ rm -f configure
+ rm -f config.log config.status
+ rm -f libtool
+ rm -f aclocal.m4
+ rm -f libopkg.pc
+ rm -f man/opkg.1 man/opkg.conf.5 man/opkg-key.1
+ rm -f Makefile Makefile.in
+ rm -f libopkg/Makefile libopkg/Makefile.in
+ rm -f man/Makefile man/Makefile.in
+ rm -f utils/Makefile utils/Makefile.in
+ rm -f src/Makefile src/Makefile.in
+ rm -f config.h config.h.in
+ rm -f m4/lt*.m4 m4/libtool.m4 m4/pkg.m4
+ rm -rf po conf autom4te.cache
+ rm -rf libopkg/.deps src/.deps
+ rm -rf libopkg/.libs src/.libs
+
+ rm -f libopkg/*.o src/*.o
+ rm -f libopkg/*.lo
+ rm -f libopkg/*.la
+ rm -f src/opkg
+ rm -f stamp-h1
+
+ rm -f tests/*.pyc tests/*.pyo
+ rm -rf tests/__pycache__
+
+ echo "Done. If you want regenerate the Autotool files call 'autogen.sh' without the '--clean' argument."
+ exit 0
+fi
+
+(autoconf --version) < /dev/null > /dev/null 2>&1 || {
+ echo
+ echo "You must have autoconf installed to compile $PACKAGE."
+ echo "Download the appropriate PACKAGE for your system,"
+ echo "or get the source from one of the GNU ftp sites"
+ echo "listed in http://www.gnu.org/order/ftp.html"
+ DIE=1
+}
+
+(automake --version) < /dev/null > /dev/null 2>&1 || {
+ echo
+ echo "You must have automake installed to compile $PACKAGE."
+ echo "Download the appropriate PACKAGE for your system,"
+ echo "or get the source from one of the GNU ftp sites"
+ echo "listed in http://www.gnu.org/order/ftp.html"
+ DIE=1
+}
+
+(libtool --version) < /dev/null > /dev/null 2>&1 || {
+ echo
+ echo "You must have libtool installed to compile $PACKAGE."
+ echo "Download the appropriate PACKAGE for your system,"
+ echo "or get the source from one of the GNU ftp sites"
+ echo "listed in http://www.gnu.org/order/ftp.html"
+ DIE=1
+}
+
+# currently gettext is not used, no need to check
+#(gettext --version) < /dev/null > /dev/null 2>&1 || {
+# echo
+# echo "You must have gettext installed to compile $PACKAGE."
+# echo "Download the appropriate PACKAGE for your system,"
+# echo "or get the source from one of the GNU ftp sites"
+# echo "listed in http://www.gnu.org/order/ftp.html"
+# DIE=1
+#}
+
+if test "$DIE" -eq 1; then
+ exit 1
+fi
+
+# Suppress warning about 'm4' directory not existing
+mkdir -p m4
+
+echo "Generating configuration files for $PACKAGE, please wait...."
+if [ "$ACLOCAL_FLAGS" = "" ]; then
+ echo "No option for 'aclocal' given. Possibly you have forgotten to use 'ACLOCAL_FLAGS='?"
+fi
+
+echo " aclocal --install -I m4 $ACLOCAL_FLAGS"
+aclocal --install -I m4 $ACLOCAL_FLAGS
+if [ "$?" = "1" ]; then
+ echo "aclocal failed!" && exit 1
+fi
+
+echo " libtoolize --automake --install"
+libtoolize --automake --install
+if [ "$?" = "1" ]; then
+ echo "libtoolize failed!" && exit 1
+fi
+
+#echo " gettextize"
+#gettextize
+#if [ "$?" = "1" ]; then
+# "echo gettextsize failed!" && exit 1
+#fi
+echo " autoconf"
+autoconf
+if [ "$?" = "1" ]; then
+ echo "autoconf failed!" && exit 1
+fi
+
+echo " autoheader"
+autoheader
+if [ "$?" = "1" ]; then
+ echo "autoheader failed!" && exit 1
+fi
+
+echo " automake --add-missing"
+automake --add-missing
+if [ "$?" = "1" ]; then
+ echo "automake failed!" && exit 1
+fi
+
+echo "You can now run 'configure [options]' to configure $PACKAGE."