summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Hansen2017-01-09 15:19:11 -0800
committerMichael Hansen2017-01-09 15:19:11 -0800
commit7dc796c2e55c75f71c2524848512da6a14b0b3b4 (patch)
tree0a8e294e1f5de0f3829506891ede622fe9d4f898
parent2c3d36e9603dcec7352abb4049ab4d115c216c2b (diff)
downloadaur-7dc796c2e55c75f71c2524848512da6a14b0b3b4.tar.gz
Update to 0.3.4
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD19
-rwxr-xr-xautogen.sh128
3 files changed, 11 insertions, 146 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 36ea1314edbb..bc9f3f4b1dc1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Thu Sep 15 03:56:43 UTC 2016
+# Mon Jan 9 23:18:58 UTC 2017
pkgbase = opkg
pkgdesc = Opkg is a lightweight package management system based upon ipkg
- pkgver = 0.3.3
+ pkgver = 0.3.4
pkgrel = 1
url = https://code.google.com/archive/p/opkg/
arch = i386
@@ -12,10 +12,8 @@ pkgbase = opkg
depends = libarchive
depends = gpgme
depends = libsolv
- source = http://downloads.yoctoproject.org/releases/opkg/opkg-0.3.3.tar.gz
- source = autogen.sh
- sha256sums = 19db9e73121a5e4c91fa228b0a6a4c55cc3591056130cfb3c66c30aa32f8d00e
- sha256sums = 72d2b5491458f0fb5fabaa5bb65482fe1fb256b39cef258029116872ed34dbe2
+ source = http://downloads.yoctoproject.org/releases/opkg/opkg-0.3.4.tar.gz
+ sha256sums = 750b900b53b62a9b280b601a196f02da81091eda2f3478c509512aa5a1ec93be
pkgname = opkg
diff --git a/PKGBUILD b/PKGBUILD
index 1a11e1bd0958..e7a4ef84547a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,24 @@
# Maintainer: Michael Hansen <zrax0111 gmail com>
pkgname=opkg
-pkgver=0.3.3
+pkgver=0.3.4
pkgrel=1
pkgdesc="Opkg is a lightweight package management system based upon ipkg"
arch=('i386' 'x86_64')
url="https://code.google.com/archive/p/opkg/"
license=('GPL')
depends=('curl' 'libarchive' 'gpgme' 'libsolv')
-source=("http://downloads.yoctoproject.org/releases/${pkgname}/${pkgname}-${pkgver}.tar.gz"
- 'autogen.sh')
-sha256sums=('19db9e73121a5e4c91fa228b0a6a4c55cc3591056130cfb3c66c30aa32f8d00e'
- '72d2b5491458f0fb5fabaa5bb65482fe1fb256b39cef258029116872ed34dbe2')
-
-prepare() {
- # This is stripped out of releases, but the provided configure script
- # doesn't work out-of-the-box on Arch
- ln -sf ../autogen.sh "${srcdir}/${pkgname}-${pkgver}/autogen.sh"
-}
+source=("http://downloads.yoctoproject.org/releases/${pkgname}/${pkgname}-${pkgver}.tar.gz")
+sha256sums=('750b900b53b62a9b280b601a196f02da81091eda2f3478c509512aa5a1ec93be')
build() {
cd ${pkgname}-${pkgver}
./autogen.sh
- ./configure --prefix=/usr --with-libsolv
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --with-libsolv
make
}
diff --git a/autogen.sh b/autogen.sh
deleted file mode 100755
index 333a1512370f..000000000000
--- a/autogen.sh
+++ /dev/null
@@ -1,128 +0,0 @@
-#!/bin/sh
-
-PACKAGE="opkg"
-
-srcdir=`dirname $0`
-test -z "$srcdir" && srcdir=.
-
-cd "$srcdir"
-DIE=0
-
-if [ \( $# -eq 1 \) -a \( "$1" = "--clean" \) ]; then
- # Deep clean of all generated files
- echo "Removing old files (no Makefile around?) ..."
- rm -f configure
- rm -f config.log config.status
- rm -f libtool
- rm -f aclocal.m4
- rm -f libopkg.pc
- rm -f man/opkg.1 man/opkg.conf.5 man/opkg-key.1
- rm -f Makefile Makefile.in
- rm -f libopkg/Makefile libopkg/Makefile.in
- rm -f man/Makefile man/Makefile.in
- rm -f utils/Makefile utils/Makefile.in
- rm -f src/Makefile src/Makefile.in
- rm -f config.h config.h.in
- rm -f m4/lt*.m4 m4/libtool.m4 m4/pkg.m4
- rm -rf po conf autom4te.cache
- rm -rf libopkg/.deps src/.deps
- rm -rf libopkg/.libs src/.libs
-
- rm -f libopkg/*.o src/*.o
- rm -f libopkg/*.lo
- rm -f libopkg/*.la
- rm -f src/opkg
- rm -f stamp-h1
-
- rm -f tests/*.pyc tests/*.pyo
- rm -rf tests/__pycache__
-
- echo "Done. If you want regenerate the Autotool files call 'autogen.sh' without the '--clean' argument."
- exit 0
-fi
-
-(autoconf --version) < /dev/null > /dev/null 2>&1 || {
- echo
- echo "You must have autoconf installed to compile $PACKAGE."
- echo "Download the appropriate PACKAGE for your system,"
- echo "or get the source from one of the GNU ftp sites"
- echo "listed in http://www.gnu.org/order/ftp.html"
- DIE=1
-}
-
-(automake --version) < /dev/null > /dev/null 2>&1 || {
- echo
- echo "You must have automake installed to compile $PACKAGE."
- echo "Download the appropriate PACKAGE for your system,"
- echo "or get the source from one of the GNU ftp sites"
- echo "listed in http://www.gnu.org/order/ftp.html"
- DIE=1
-}
-
-(libtool --version) < /dev/null > /dev/null 2>&1 || {
- echo
- echo "You must have libtool installed to compile $PACKAGE."
- echo "Download the appropriate PACKAGE for your system,"
- echo "or get the source from one of the GNU ftp sites"
- echo "listed in http://www.gnu.org/order/ftp.html"
- DIE=1
-}
-
-# currently gettext is not used, no need to check
-#(gettext --version) < /dev/null > /dev/null 2>&1 || {
-# echo
-# echo "You must have gettext installed to compile $PACKAGE."
-# echo "Download the appropriate PACKAGE for your system,"
-# echo "or get the source from one of the GNU ftp sites"
-# echo "listed in http://www.gnu.org/order/ftp.html"
-# DIE=1
-#}
-
-if test "$DIE" -eq 1; then
- exit 1
-fi
-
-# Suppress warning about 'm4' directory not existing
-mkdir -p m4
-
-echo "Generating configuration files for $PACKAGE, please wait...."
-if [ "$ACLOCAL_FLAGS" = "" ]; then
- echo "No option for 'aclocal' given. Possibly you have forgotten to use 'ACLOCAL_FLAGS='?"
-fi
-
-echo " aclocal --install -I m4 $ACLOCAL_FLAGS"
-aclocal --install -I m4 $ACLOCAL_FLAGS
-if [ "$?" = "1" ]; then
- echo "aclocal failed!" && exit 1
-fi
-
-echo " libtoolize --automake --install"
-libtoolize --automake --install
-if [ "$?" = "1" ]; then
- echo "libtoolize failed!" && exit 1
-fi
-
-#echo " gettextize"
-#gettextize
-#if [ "$?" = "1" ]; then
-# "echo gettextsize failed!" && exit 1
-#fi
-echo " autoconf"
-autoconf
-if [ "$?" = "1" ]; then
- echo "autoconf failed!" && exit 1
-fi
-
-echo " autoheader"
-autoheader
-if [ "$?" = "1" ]; then
- echo "autoheader failed!" && exit 1
-fi
-
-echo " automake --add-missing"
-automake --add-missing
-if [ "$?" = "1" ]; then
- echo "automake failed!" && exit 1
-fi
-
-echo "You can now run 'configure [options]' to configure $PACKAGE."