summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIlya Lipnitskiy2016-02-23 21:40:49 -0800
committerIlya Lipnitskiy2016-02-23 21:40:49 -0800
commitccda3cf95b546724c181cdfc4127ed3bd4d1f5b2 (patch)
tree3a0cbf9e00f519c06a71685ef8216a1333fd69bb
parentbdb170beac2addcfb72a9077f4d6779993ae8a8b (diff)
downloadaur-ccda3cf95b546724c181cdfc4127ed3bd4d1f5b2.tar.gz
Update to v0.3.1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD21
2 files changed, 12 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6e6e387b2e12..a64b794c9008 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
+# Generated by mksrcinfo v8
+# Wed Feb 24 05:40:38 UTC 2016
pkgbase = opkg-git
pkgdesc = Opkg is a lightweight package management system based upon ipkg
- pkgver = v0.3.0.r35.f48bbea
+ pkgver = v0.3.1
pkgrel = 1
url = https://git.yoctoproject.org/cgit/cgit.cgi/opkg
arch = x86_64
license = GPL
- makedepends = git
depends = curl
depends = libarchive
depends = gpgme
- conflicts = opkg
- source = git+http://git.yoctoproject.org/git/opkg#branch=opkg-0.3.x
- sha256sums = SKIP
+ source = https://git.yoctoproject.org/cgit/cgit.cgi/opkg/snapshot/opkg-v0.3.1.tar.gz
+ sha256sums = 994182896ce8fdaa60f8af07a0c7e29ef770f20a69742fb606cb3b450e02aeaf
pkgname = opkg-git
diff --git a/PKGBUILD b/PKGBUILD
index 703ac01c2a4a..cbc5b9642d43 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,28 @@
# Maintainer: Ilya Lipnitskiy <ilya.lipnitskiy@gmail.com>
pkgname=opkg-git
-pkgver=v0.3.0.r35.f48bbea
+pkgver=v0.3.1
pkgrel=1
pkgdesc="Opkg is a lightweight package management system based upon ipkg"
arch=(x86_64)
url="https://git.yoctoproject.org/cgit/cgit.cgi/opkg"
license=('GPL')
depends=('curl' 'libarchive' 'gpgme')
-makedepends=('git')
-conflicts=(opkg)
-source=("git+http://git.yoctoproject.org/git/opkg#branch=opkg-0.3.x")
-sha256sums=('SKIP')
-
-pkgver() {
- cd opkg
- printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
-}
+source=("${url}/snapshot/${pkgname%-git}-${pkgver}.tar.gz")
+sha256sums=('994182896ce8fdaa60f8af07a0c7e29ef770f20a69742fb606cb3b450e02aeaf')
prepare() {
- cd opkg
+ cd ${pkgname%-git}-${pkgver}
./autogen.sh
./configure --prefix=/usr
}
build() {
- cd opkg
+ cd ${pkgname%-git}-${pkgver}
make
}
package() {
- cd opkg
- make DESTDIR="$pkgdir/" install
+ cd ${pkgname%-git}-${pkgver}
+ make DESTDIR="${pkgdir}/" install
}