summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIlya Lipnitskiy2016-02-02 20:08:30 -0800
committerIlya Lipnitskiy2016-02-02 20:08:30 -0800
commitb70cb9e851db5ba5f1b2b56ee8518f75a0936d92 (patch)
tree1cb8df0bef773a4dde55feac3216701dd3bbee35
downloadaur-b70cb9e851db5ba5f1b2b56ee8518f75a0936d92.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD28
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cfb9b6453e8f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Wed Feb 3 04:07:57 UTC 2016
+pkgbase = opkg-utils-git
+ pkgdesc = Helper scripts for use with the opkg package manager
+ pkgver = r60.fc6eb29
+ pkgrel = 1
+ url = https://git.yoctoproject.org/cgit/cgit.cgi/opkg-utils
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ conflicts = opkg-utils
+ source = git+http://git.yoctoproject.org/git/opkg-utils#branch=master
+ sha256sums = SKIP
+
+pkgname = opkg-utils-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a80566ba1d53
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Ilya Lipnitskiy <ilya.lipnitskiy@gmail.com>
+
+pkgname=opkg-utils-git
+pkgver=r60.fc6eb29
+pkgrel=1
+pkgdesc="Helper scripts for use with the opkg package manager"
+arch=('x86_64')
+url="https://git.yoctoproject.org/cgit/cgit.cgi/opkg-utils"
+license=('GPL')
+makedepends=('git')
+conflicts=(opkg-utils)
+source=("git+http://git.yoctoproject.org/git/opkg-utils#branch=master")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd opkg-utils
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd opkg-utils
+ make
+}
+
+package() {
+ cd opkg-utils
+ make PREFIX="/usr" DESTDIR="$pkgdir/" install
+}