summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJP Cimalando2018-06-16 17:33:30 +0200
committerJP Cimalando2018-06-16 17:33:30 +0200
commitbc9fb5da4624d05b03bbd90cd88c9c8ff8802a1b (patch)
treedba2042c5f3f4a32e20f072d11fece0cf1840d7f
parent56dd54a6e51b0e693b67b1d503100fb6223823ad (diff)
downloadaur-bc9fb5da4624d05b03bbd90cd88c9c8ff8802a1b.tar.gz
update for cmake build with support of Jack and Pulseaudio
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 10 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c14dc3c0f2a4..cc78252b2adc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,14 @@
pkgbase = opl3bankeditor-git
pkgdesc = A small cross-platform editor of the OPL3 FM banks of different formats
- pkgver = 1.3.beta.r176.g8b5b03f
+ pkgver = 1.3.beta.r318.gbdd6f06
pkgrel = 1
url = https://github.com/Wohlstand/OPL3BankEditor
arch = i686
arch = x86_64
license = GPL3
- depends = qt5-multimedia
+ depends = qt5-base
+ depends = jack
+ depends = libpulse
provides = opl3bankeditor
conflicts = opl3bankeditor
source = git+https://github.com/Wohlstand/OPL3BankEditor.git
diff --git a/PKGBUILD b/PKGBUILD
index d9cca328cc11..c1e85221b109 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: JP Cimalando <jp-dev inbox.ru>
pkgname=opl3bankeditor-git
_pkgname=OPL3BankEditor
-pkgver=1.3.beta.r176.g8b5b03f
+pkgver=1.3.beta.r318.gbdd6f06
pkgrel=1
epoch=
pkgdesc="A small cross-platform editor of the OPL3 FM banks of different formats"
@@ -9,7 +9,7 @@ arch=('i686' 'x86_64')
url="https://github.com/Wohlstand/OPL3BankEditor"
license=('GPL3')
groups=()
-depends=('qt5-multimedia')
+depends=('qt5-base' 'jack' 'libpulse')
makedepends=()
checkdepends=()
optdepends=()
@@ -40,13 +40,15 @@ prepare() {
build() {
cd "$_pkgname"
- qmake
+ mkdir -p build
+ cd build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release ..
make
}
package() {
cd "$_pkgname"
- install -D -m755 bin-debug/opl3_bank_editor "$pkgdir"/usr/bin/opl3_bank_editor
+ make -C build install DESTDIR="$pkgdir"
install -D -m644 src/resources/opl3_48.png "$pkgdir"/usr/share/pixmaps/opl3_bank_editor.png
install -D -m644 "$srcdir"/opl3_bank_editor.desktop "$pkgdir"/usr/share/applications/opl3_bank_editor.desktop
}