summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMoritz Lipp2015-06-15 20:18:05 +0200
committerMoritz Lipp2015-06-15 20:18:05 +0200
commit2aa8412dd34d7d1ea5b0a4d63fe668ee58b56005 (patch)
treeb3ee022e589f95a0add45db5234e36be0377794a
downloadaur-2aa8412dd34d7d1ea5b0a4d63fe668ee58b56005.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD23
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7f7cb7bcce34
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = opmsg
+ pkgdesc = opmsg message encryption
+ pkgver = 1.2s
+ pkgrel = 1
+ url = https://github.com/stealth/opmsg
+ arch = x86_64
+ arch = i686
+ license = GPL3
+ depends = openssl
+ source = https://github.com/stealth/opmsg/archive/rel-1.2s.tar.gz
+ md5sums = 308ee318a3ae1c264d653d6f3b387303
+
+pkgname = opmsg
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e56c7467433b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Moritz Lipp <mail@mlq.me>
+pkgname=opmsg
+pkgver=1.2s
+_pkgver=rel-"${pkgver}"
+pkgrel=1
+epoch=
+pkgdesc="opmsg message encryption"
+arch=('x86_64' 'i686')
+url="https://github.com/stealth/opmsg"
+license=('GPL3')
+depends=('openssl')
+source=("https://github.com/stealth/${pkgname}/archive/${_pkgver}.tar.gz")
+md5sums=('308ee318a3ae1c264d653d6f3b387303')
+
+build() {
+ cd "$pkgname-$_pkgver"
+ make
+}
+
+package() {
+ cd "$pkgname-$_pkgver"
+ install -D -m755 opmsg "$pkgdir/usr/bin/opmsg"
+}