summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJP Cimalando2018-09-22 18:35:02 +0200
committerJP Cimalando2018-09-22 18:35:02 +0200
commitc1e01c1e7badbf4952b274e1e31c6bb8e5839ece (patch)
tree90438daf7df4281f6330b04e48408e24223b5cb7
downloadaur-c1e01c1e7badbf4952b274e1e31c6bb8e5839ece.tar.gz
initial
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD50
2 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3720747f13fa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = opn2bankeditor-git
+ pkgdesc = A small cross-platform editor of the OPN2 FM banks of different formats
+ pkgver = 1.3.beta.r1.g6bad9cc
+ pkgrel = 1
+ url = https://github.com/Wohlstand/OPN2BankEditor
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = qt5-base
+ depends = qwt
+ depends = jack
+ depends = libpulse
+ provides = opn2bankeditor
+ conflicts = opn2bankeditor
+ source = git+https://github.com/Wohlstand/OPN2BankEditor.git
+ md5sums = SKIP
+
+pkgname = opn2bankeditor-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f6d1548bbd4c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: JP Cimalando <jp-dev inbox.ru>
+pkgname=opn2bankeditor-git
+_pkgname=OPN2BankEditor
+pkgver=1.3.beta.r1.g6bad9cc
+pkgrel=1
+epoch=
+pkgdesc="A small cross-platform editor of the OPN2 FM banks of different formats"
+arch=('i686' 'x86_64')
+url="https://github.com/Wohlstand/OPN2BankEditor"
+license=('GPL3')
+groups=()
+depends=('qt5-base' 'qwt' 'jack' 'libpulse')
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=("opn2bankeditor")
+conflicts=("opn2bankeditor")
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("git+https://github.com/Wohlstand/${_pkgname}.git")
+noextract=()
+md5sums=('SKIP')
+validpgpkeys=()
+
+pkgver() {
+ cd "$_pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd "$_pkgname"
+ git submodule init
+ git submodule update
+}
+
+build() {
+ cd "$_pkgname"
+ mkdir -p build
+ cd build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release ..
+ make
+}
+
+package() {
+ cd "$_pkgname"
+ make -C build install DESTDIR="$pkgdir"
+}