summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJelle van der Waa2020-07-10 20:22:30 +0200
committerJelle van der Waa2020-07-10 20:22:30 +0200
commitef2a42b84d3b637e66dd1b71e9c147971a72d3e1 (patch)
treea5b3e35e815aaafd7ba13e6c04177b571237f2cf
downloadaur-ef2a42b84d3b637e66dd1b71e9c147971a72d3e1.tar.gz
import from community
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD43
-rw-r--r--oprofile.sysusers1
3 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..727787c6c882
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = oprofile
+ pkgdesc = System-wide profiler for Linux systems
+ pkgver = 1.3.0
+ pkgrel = 1
+ url = http://oprofile.sourceforge.net
+ arch = x86_64
+ license = GPL
+ depends = popt
+ depends = gcc-libs
+ depends = zlib
+ depends = sh
+ options = staticlibs
+ source = https://downloads.sourceforge.net/sourceforge/oprofile/oprofile-1.3.0.tar.gz
+ source = oprofile.sysusers
+ sha1sums = 7daa0cca8587e399cb3df9eb817c6a39ffea2082
+ sha1sums = efcd625073759b69f95cf74dbb4c2839e03af017
+
+pkgname = oprofile
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4e0db1d700c2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer : Aaron Griffin <aaron@archlinux.org>
+
+pkgname=oprofile
+pkgver=1.3.0
+pkgrel=1
+pkgdesc='System-wide profiler for Linux systems'
+arch=('x86_64')
+url="http://oprofile.sourceforge.net"
+license=('GPL')
+depends=('popt' 'gcc-libs' 'zlib' 'sh')
+options=('staticlibs')
+source=(https://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.gz
+ oprofile.sysusers)
+sha1sums=('7daa0cca8587e399cb3df9eb817c6a39ffea2082'
+ 'efcd625073759b69f95cf74dbb4c2839e03af017')
+
+build() {
+ cd $pkgname-$pkgver
+#CXXFLAGS+=" -std=gnu++03"
+ ./configure --prefix=/usr --with-x
+ make
+}
+
+check() {
+ cd $pkgname-$pkgver
+ make check
+}
+
+package() {
+ cd $pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
+ install -d "$pkgdir/var/lib/oprofile"
+
+# installing development libraries and headers - FS#20089
+ install -d "$pkgdir/usr/include/oprofile"
+ install -m644 config.h libop/op_*.h libregex/op_*.h libdb/odb.h \
+ libpp/{locate_images.h,image_errors.h} libutil/op_*.h \
+ libutil++/{op_*.h,bfd_support.h,utility.h,cached_value.h} "$pkgdir/usr/include/oprofile"
+ install -m644 libop/libop.a libdb/libodb.a "$pkgdir/usr/lib/"
+ install -m644 libabi/libabi.a "$pkgdir/usr/lib/libopabi.a"
+ install -m644 libutil/libutil.a "$pkgdir/usr/lib/liboputil.a"
+ install -m644 libutil++/libutil++.a "$pkgdir/usr/lib/liboputil++.a"
+}
diff --git a/oprofile.sysusers b/oprofile.sysusers
new file mode 100644
index 000000000000..4626d64de888
--- /dev/null
+++ b/oprofile.sysusers
@@ -0,0 +1 @@
+u oprofile 492 - /var/lib/oprofile