summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-05-20 11:07:30 +0300
committerDimitris Kiziridis2020-05-20 11:07:30 +0300
commit808c7df8636fa4ba3dea96792f276c4f3626b95d (patch)
treeac875367a6f42cb900e2b19d4c9892582f2012dc
parentecfdf0a8004329938f79dea85b637b340cdf7057 (diff)
downloadaur-808c7df8636fa4ba3dea96792f276c4f3626b95d.tar.gz
update pkgbuild, go-pie replaced
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD20
2 files changed, 11 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 34002eb30bb5..679321df3888 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,7 +5,7 @@ pkgbase = ops
url = https://ops.city
arch = x86_64
license = MIT
- makedepends = go-pie
+ makedepends = go
depends = glibc
source = ops-0.1.10.tar.gz::https://github.com/nanovms/ops/archive/0.1.10.tar.gz
sha256sums = c45d094e3fe8fb51878e0befeefce90d7492cce03f9d17cf0f47420cc6c40d73
diff --git a/PKGBUILD b/PKGBUILD
index c6b71e358539..0a4962204cae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,28 +8,28 @@ arch=('x86_64')
url='https://ops.city'
license=('MIT')
depends=('glibc')
-makedepends=('go-pie')
+makedepends=('go')
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/nanovms/ops/archive/${pkgver}.tar.gz")
sha256sums=('c45d094e3fe8fb51878e0befeefce90d7492cce03f9d17cf0f47420cc6c40d73')
prepare() {
cd "${srcdir}/${pkgname}-${pkgver}"
- mkdir -p $srcdir/go
- export GOPATH="${srcdir}"/go
- export PATH=$PATH:$GOPATH/bin
- make deps
+ mkdir -p build/
}
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
- export GOPATH="${srcdir}"/go
- export PATH=$PATH:$GOPATH/bin
- make build
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -modcacherw"
+ # go get -d -v ./...
+ go build -o build ./...
}
package() {
cd "${srcdir}/${pkgname}-${pkgver}"
- install -Dm755 ops "${pkgdir}/usr/bin/ops"
+ install -Dm755 build/ops "${pkgdir}/usr/bin/ops"
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/ops/LICENSE"
- go clean -modcache #Remove go local cache
} \ No newline at end of file