summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLucki2015-09-02 12:53:15 +0200
committerLucki2015-09-02 12:53:15 +0200
commitbcd41550cbf79fad742e89c08925bdc1e7d12c8e (patch)
tree338774b827d0cca2d8a005510196522cbc3f47b4
parent29db499b1c7c03a9ce48d04911b4177a84c69bdf (diff)
downloadaur-bcd41550cbf79fad742e89c08925bdc1e7d12c8e.tar.gz
Update to 0.11.0
-rw-r--r--.CHANGELOG34
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD37
-rw-r--r--pom.patch12
4 files changed, 41 insertions, 48 deletions
diff --git a/.CHANGELOG b/.CHANGELOG
index dec2c3c3f93d..51f18240d376 100644
--- a/.CHANGELOG
+++ b/.CHANGELOG
@@ -1,4 +1,32 @@
-This is primarily a bug fix release.
+This version contains a large number of bug fixes, some new features, and UI improvements.
+There were also important internal changes that are outlined below.
- Fixed a major rendering issue when using the "Flashlight" mod with the new slider style. (#108)
- Updated Maven dependencies to their latest versions (LWJGL 2, Slick2D, Commons Compress, lzma-java, maven-artifact).
+New:
+
+ Added an animation library for all-around better animations. (c91146b)
+ Implemented the "Hidden" mod, which marks the completion of the core game mods. (#115, 34c7942)
+ Added YaS Online, Mnetwork, and MengSky download servers; removed the now-offline osu!Mirror server. (dbb5eeb, 8173b9b, bd8e35c)
+ Improved the appearance of the updater UI. (f22498a)
+ Lowered GLSL version requirement for the new slider style from 330 to 110. (#122, #124)
+ Added a watch service to monitor the beatmap directory tree for changes (disabled by default). (949b2c2)
+
+Bug fixes:
+
+ Fixed wrong rank icons and wrong "Hard Rock" coordinates during replays. (#116, #118)
+ Fixed scores almost always failing to be deleted. (e68bcf8)
+ Fixed HP not being drained while holding sliders. (#103)
+ Now using official formulas for circle diameter and timing offsets. (8892973)
+ With "Show Perfect Hits" disabled, hit animations are now shown instead of objects disappearing immediately. (6e7de65)
+ Fixed game ranking screen issues: "retry" button only appears when necessary, and watching a "replay" with "Auto" is no longer treated as a replay. (130f9bf)
+ Fixed old-style skinned cursors being ignored, and the cursor-middle image is no longer scaled when clicking. (5efb61d, 40ab947)
+ Fixed crashes when trying to load audio files that were moved, and when unable to connect to the beatmap database. (ae5016f, #111)
+ Fixed some broken logic when handling misnamed MP3/OGG files. (20d40dd)
+ Fixed interrupted downloads still being marked "complete". (aed5163)
+ Fixed two incorrect shortcut keys in the game mod menu. (96f882b)
+
+Internal updates:
+
+ Added Gradle build system; see the readme for details. (#126)
+ Removed JarSplice from the build cycle, and incorporated a native loader into opsu!.
+ Removed the jinput dependency.
+ Documented all files/directories created by opsu! in the readme.
diff --git a/.SRCINFO b/.SRCINFO
index c69a888d57eb..16c285efb24a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = opsu
pkgdesc = An open source osu!-client written in Java.
- pkgver = 0.10.1
+ pkgver = 0.11.0
pkgrel = 1
url = https://itdelatrisu.github.io/opsu/
changelog = .CHANGELOG
@@ -15,11 +15,9 @@ pkgbase = opsu
depends = bash
provides = opsu
conflicts = opsu
- source = opsu::git://github.com/itdelatrisu/opsu.git#tag=0.10.1
- source = pom.patch
+ source = opsu::git://github.com/itdelatrisu/opsu.git#tag=0.11.0
source = opsu.sh
sha512sums = SKIP
- sha512sums = 72c56c8f0c647fcdbf85a32e7c4bf1a37b7176015f08402dc20b707f11c5cbb78be1da81d4a697c9d842ac28a9a0bcf1f4c8252c2a18e2ee35435cd327da683b
sha512sums = 4b065052fef55e1860a51dfa5af080930b1001e4c82cd8b3b0383bd68b239d382d788408235a7cb4fb4a1d04123a6049188a2e2c2d0e5fd08a3deb69da25fc2d
pkgname = opsu
diff --git a/PKGBUILD b/PKGBUILD
index a3b979401271..5787cb661012 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Lucki <Lucki at holarse-linuxgaming dot de>
pkgname=opsu
-pkgver=0.10.1
+pkgver=0.11.0
pkgrel=1
pkgdesc="An open source osu!-client written in Java."
arch=('any')
@@ -13,15 +13,13 @@ makedepends=('java-environment' 'java-web-start' 'maven' 'gendesk' 'git')
provides=('opsu')
conflicts=('opsu')
source=( ${pkgname}::git://github.com/itdelatrisu/opsu.git#tag=${pkgver}
- pom.patch
opsu.sh )
sha512sums=('SKIP'
- '72c56c8f0c647fcdbf85a32e7c4bf1a37b7176015f08402dc20b707f11c5cbb78be1da81d4a697c9d842ac28a9a0bcf1f4c8252c2a18e2ee35435cd327da683b'
'4b065052fef55e1860a51dfa5af080930b1001e4c82cd8b3b0383bd68b239d382d788408235a7cb4fb4a1d04123a6049188a2e2c2d0e5fd08a3deb69da25fc2d')
pkgver()
{
- cd ${srcdir}/${pkgname}
+ cd "${srcdir}/${pkgname}"
git describe --tags | sed 's/-.*//'
}
@@ -29,37 +27,18 @@ prepare()
{
# generate .desktop-file
gendesk -n -f --pkgname ${pkgname} --pkgdesc "$pkgdesc" --name "opsu!" --exec "${pkgname}" --categories "Game"
-
- # update .CHANGELOG
- # git -C ${srcdir}/${pkgname} log --graph -10 0.1.0..${pkgver} > ${startdir}/.CHANGELOG
-
- # check for openjdk
- if [[ ! $(archlinux-java get | sed -r 's/.*(.{7})/\1/') == "openjdk" ]]; then
- msg "OpenJDK not found, using OracleJDK"
-
- # cut patch
- sed -e '4q' ${srcdir}/pom.patch > ${srcdir}/pom2.patch
-
- # patch pom.xml
- patch ${srcdir}/${pkgname}/pom.xml ${srcdir}/pom2.patch
- else
- msg "OpenJDK found, using systempath"
-
- # patch pom.xml
- patch ${srcdir}/${pkgname}/pom.xml ${srcdir}/pom.patch
- fi
}
build()
{
- cd ${srcdir}/${pkgname}
- mvn install -Djar
+ cd "${srcdir}/${pkgname}"
+ gradle jar -PXDG=true
}
package()
{
- install -Dm644 ${srcdir}/${pkgname}/target/${pkgname}-${pkgver}-runnable.jar ${pkgdir}/usr/share/java/${pkgname}/${pkgname}.jar
- install -Dm644 ${srcdir}/${pkgname}/res/logo.png ${pkgdir}/usr/share/pixmaps/${pkgname}.png
- install -Dm644 ${pkgname}.desktop ${pkgdir}/usr/share/applications/${pkgname}.desktop
- install -Dm755 ${pkgname}.sh ${pkgdir}/usr/bin/${pkgname}
+ install -Dm644 "${srcdir}/${pkgname}/build/libs/${pkgname}-${pkgver}.jar" "${pkgdir}/usr/share/java/${pkgname}/${pkgname}.jar"
+ install -Dm644 "${srcdir}/${pkgname}/res/logo.png" "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
+ install -Dm644 "${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+ install -Dm755 "${pkgname}.sh" "${pkgdir}/usr/bin/${pkgname}"
}
diff --git a/pom.patch b/pom.patch
deleted file mode 100644
index d59c961965e4..000000000000
--- a/pom.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-92c92
-< <!--<argument>-Dparams=-DXDG=true</argument>-->
----
-> <argument>-Dparams=-DXDG=true</argument>
-151a152,158
-> <dependency>
-> <groupId>javax.jnlp</groupId>
-> <artifactId>jnlp-api</artifactId>
-> <version>1.0.0</version>
-> <scope>system</scope>
-> <systemPath>/usr/bin/javaws</systemPath>
-> </dependency>