summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLucki2015-07-05 15:10:18 +0200
committerLucki2015-07-05 15:10:18 +0200
commitdca7128f7af2e29689bd4f3cc9dc0e43c0426ee2 (patch)
tree5a54ba3a63f637bc7d76458004b480680d07d9a1
parent9ecd24d2aec4f37905c67409c923ad73177ce494 (diff)
downloadaur-dca7128f7af2e29689bd4f3cc9dc0e43c0426ee2.tar.gz
Update to 0.10.0
-rw-r--r--.CHANGELOG153
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
3 files changed, 88 insertions, 69 deletions
diff --git a/.CHANGELOG b/.CHANGELOG
index 8a11b69c297e..326540c796f5 100644
--- a/.CHANGELOG
+++ b/.CHANGELOG
@@ -1,93 +1,112 @@
-* commit 92f4a5176d09d82cfd481e4de0db9abbb2265185
+* commit 47f682352dd65cb322fb02907af219ba5e882472
| Author: Jeffrey Han <itdelatrisu@gmail.com>
-| Date: Tue Jun 9 03:10:44 2015 -0400
+| Date: Sat Jul 4 23:29:46 2015 -0500
|
-| Switch to a LRU cache for beatmap background images.
-| Created a separate BeatmapImageCache class to handle cache operations. The cache now uses File objects as keys, rather than Beatmap objects (which was buggy).
-|
-| Also renamed "OsuHitObjectResult" helper class to "HitObjectResult".
+| Updating to version 0.10.0.
|
| Signed-off-by: Jeffrey Han <itdelatrisu@gmail.com>
|
-* commit 74f7ac18b9d9f8d10db11b4fa0c7b061e5294d8b
+* commit 2167698740086dd06ffb242bf203a6f14eeb09e8
| Author: Jeffrey Han <itdelatrisu@gmail.com>
-| Date: Mon Jun 8 18:13:49 2015 -0400
+| Date: Thu Jul 2 22:16:14 2015 -0500
|
-| Fixed an infinite loop on beatmaps starting at time 0. (blame: 18e57fd)
-| There's probably a better fix, though...
+| Follow-up to #99: replay seeking improvements.
+| - Added on/off option for replay seeking in the "custom" menu.
+| - Mute sounds while seeking.
+| - Draw a bar on the left of the screen during replays for seeking (instead of just clicking near the top of the screen).
|
| Signed-off-by: Jeffrey Han <itdelatrisu@gmail.com>
|
-* commit e712d57a2c11e4ca5d9e6ac9607d3c9f7bb9bc0e
+* commit 495a7e7f8b01116307c81e3767d68e19c30a8361
| Author: Jeffrey Han <itdelatrisu@gmail.com>
-| Date: Mon Jun 8 17:23:45 2015 -0400
+| Date: Mon Jun 29 20:18:28 2015 -0500
|
-| Cleaned up implementation of beatmap combo colors.
-| Added getComboColors() method to Beatmap class, and the 'combo' field is now null if no combo is provided.
+| Follow-up to d860a30: replay importing fixes.
+| - Move failed imports to a "failed" subdirectory so that errors aren't generated each time the program is launched.
+| - Importing now overwrites files.
+| - Add "ReplayImportDirectory" option to config file.
+| - Fixed a bug with scores not being properly added.
|
| Signed-off-by: Jeffrey Han <itdelatrisu@gmail.com>
|
-* commit b1b1664e1118704f8d70643b6c5d57c63f09fbff
+* commit d860a30aed3dcca31ac15e700e09bb93f2db51a1
| Author: Jeffrey Han <itdelatrisu@gmail.com>
-| Date: Mon Jun 8 16:42:54 2015 -0400
+| Date: Mon Jun 29 19:22:38 2015 -0500
|
-| Follow-up to #91.
-| Pass the border color into CurveRenderState instead of determining it there; store the color as a static field in Curve (since it shouldn't change per-beatmap).
-|
-| Also removed the leftover FrameBufferCache warning from #64.
+| Follow-up to #99.
+| - Many code style changes.
+| - Don't increment combo if missing the last slider circle.
+| - Added player name in ranking screen.
+| - Don't show null/default player names.
+| - Only import replays with .osr extension.
+| - Display loading status for importing replays.
+| - Moved MD5InputStreamWrapper to package "opsu.io".
|
| Signed-off-by: Jeffrey Han <itdelatrisu@gmail.com>
|
-* commit a7d05a4b2619fec025a3b4a0e67c7a9e4aa3f31a
-|\ Merge: 447a0f3 890a69c
+* commit 7d08a7d39128a3d0d14485a888adadb3714630d5
+|\ Merge: 52cb5d2 5562803
| | Author: Jeffrey Han <itdelatrisu@users.noreply.github.com>
-| | Date: Mon Jun 8 16:22:03 2015 -0400
+| | Date: Sun Jun 28 21:14:10 2015 -0500
| |
-| | Merge pull request #91 from Bigpet/bordercolor
+| | Merge pull request #99 from fluddokt/ReplayTest
| |
-| | recolor the slider border from the skin or beatmap settings
+| | Replay importing, spinner fixes (fixes #67), replay seeking, in-place MD5 calculation, pitch change time sync (fixes #86).
| |
-| * commit 890a69c1a93b718a5fd622b04f9fe0b57bbcfab0
-|/ Author: Peter Tissen <dravorek@gmail.com>
-| Date: Mon Jun 8 22:07:24 2015 +0200
-|
-| recolor the slider border from the skin or beatmap settings
-|
-* commit 447a0f371a45512cec8495e064bb5cfcb2a38cc6
-| Author: Jeffrey Han <itdelatrisu@gmail.com>
-| Date: Mon Jun 8 15:57:17 2015 -0400
-|
-| Added missing "SliderBorder" field to BeatmapParser.
-| Use beatmap.getSliderBorderColor() to get the slider border color for a beatmap.
-|
-| Also adds the field to the beatmap cache, and fixes a bug where format changes would cause an exception when preparing statements in the new format.
-|
-| Signed-off-by: Jeffrey Han <itdelatrisu@gmail.com>
-|
-* commit b6f208a47d017c5bdc9054711e67cee7e280a788
-| Author: Jeffrey Han <itdelatrisu@gmail.com>
-| Date: Mon Jun 8 15:02:28 2015 -0400
-|
-| Follow-up to #64.
-| - Removed NEW_SLIDER option, and use the skin "SliderStyle" instead. Uses the new style by default, unless STYLE_PEPPYSLIDER is specified.
-| - Check if OpenGL 3.0 is supported before trying to draw new style sliders.
-| - Fixed compilation warnings; removed unneeded fields and imports.
-| - Filled in some missing Javadocs.
-| - Style changes.
-|
-| Signed-off-by: Jeffrey Han <itdelatrisu@gmail.com>
-|
-* commit 9c8a8f24c6982b7b1c18fe6c1243d6e40f2607a2
-|\ Merge: 90c8c9e 609739e
-| | Author: Jeffrey Han <itdelatrisu@users.noreply.github.com>
-| | Date: Mon Jun 8 13:58:08 2015 -0400
+| * commit 55628038feb5390b37061cd5778eb22e53fb9bbf
+| | Author: fd <fd@b>
+| | Date: Sun Jun 21 22:57:30 2015 -0400
| |
-| | Merge pull request #64 from Bigpet/sliderrender
+| | Restores drainRate
| |
-| | Slider rendering to offscreen buffer
-| |
-| * commit 609739e153bd12b17165f1394ad191b3a3c9e0de
-| | Author: Peter Tissen <dravorek@gmail.com>
-| | Date: Mon Jun 8 19:11:07 2015 +0200
-| |
-| | ignore UIScale for reading raw image pixels
+| | Single file read md5
+| |
+| | pitch change synctime
+| |
+| * commit df07c626095eb8b7c9054a4715bd5ba8acc2f4ed
+| |\ Merge: 3675a25 81d9421
+| | | Author: fd <fd@b>
+| | | Date: Sun Jun 21 20:05:36 2015 -0400
+| | |
+| | | Merge remote-tracking branch 'org/master' into ReplayTest
+| | |
+| | | Conflicts:
+| | | src/itdelatrisu/opsu/GameData.java
+| | | src/itdelatrisu/opsu/states/Game.java
+| | |
+| * | commit 3675a25c44dcf527a6f0a19871ba58c69d1d16b4
+| | | Author: fd <fd@b>
+| | | Date: Sun Jun 21 19:45:38 2015 -0400
+| | |
+| | | Spinner Test 3
+| | |
+| | | Clean up
+| | |
+| * | commit 038a5d57799d1d8899afaf64a12199478f01f634
+| | | Author: fd <fd@b>
+| | | Date: Sat Jun 13 21:16:27 2015 -0400
+| | |
+| | | WIPTest Merge Fixes
+| | |
+| * | commit fd3f7fdabe3aede7037c33d38625e2f0bac193ef
+| |\ \ Merge: 40e67ce 85c2328
+| | | | Author: fd <fd@b>
+| | | | Date: Sat Jun 13 20:28:30 2015 -0400
+| | | |
+| | | | Merge remote-tracking branch 'org/master' into ReplayTest
+| | | |
+| | | | Conflicts:
+| | | | src/itdelatrisu/opsu/GameData.java
+| | | | src/itdelatrisu/opsu/Options.java
+| | | | src/itdelatrisu/opsu/OsuFile.java
+| | | | src/itdelatrisu/opsu/OsuGroupList.java
+| | | | src/itdelatrisu/opsu/OsuHitObject.java
+| | | | src/itdelatrisu/opsu/OsuParser.java
+| | | | src/itdelatrisu/opsu/UI.java
+| | | | src/itdelatrisu/opsu/db/OsuDB.java
+| | | | src/itdelatrisu/opsu/objects/Circle.java
+| | | | src/itdelatrisu/opsu/objects/HitObject.java
+| | | | src/itdelatrisu/opsu/objects/Slider.java
+| | | | src/itdelatrisu/opsu/objects/Spinner.java
+| | | | src/itdelatrisu/opsu/states/Game.java
+| | | | src/itdelatrisu/opsu/states/Splash.java
diff --git a/.SRCINFO b/.SRCINFO
index e4a82edd14cb..709f0aa56bcc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = opsu-git
pkgdesc = An open source osu!-client written in Java.
- pkgver = 0.9.0.r22.g92f4a51
+ pkgver = 0.10.0.r0.g47f6823
pkgrel = 1
url = https://itdelatrisu.github.io/opsu/
changelog = .CHANGELOG
diff --git a/PKGBUILD b/PKGBUILD
index bc6694591e01..9a06d67b7cdd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: Lucki <Lucki at holarse-linuxgaming dot de>
pkgname=opsu-git
-pkgver=0.9.0.r22.g92f4a51
+pkgver=0.10.0.r0.g47f6823
pkgrel=1
pkgdesc="An open source osu!-client written in Java."
arch=('any')