summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShatur952021-02-28 16:48:08 +0200
committerShatur952021-02-28 16:48:39 +0200
commit1f48f639044bb285b377c327e3c683d9c4971bc3 (patch)
tree985ee0b569ae6166ea554101b34c6a0fe68f46b0
parent1b956d0ff5dd54aff7655644fda8ba5ded9d4c63 (diff)
downloadaur-1f48f639044bb285b377c327e3c683d9c4971bc3.tar.gz
Update to 1.6.0
-rwxr-xr-x.SRCINFO12
-rwxr-xr-xPKGBUILD30
2 files changed, 15 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7e3ac7baec76..09b4159268c0 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,19 @@
pkgbase = optimus-manager-qt
pkgdesc = A Qt interface for Optimus Manager that allows to configure and switch GPUs on Optimus laptops using the tray menu
- pkgver = 1.5.3
+ pkgver = 1.6.0
pkgrel = 1
url = https://github.com/Shatur95/optimus-manager-qt
arch = x86_64
license = GPL3
makedepends = qt5-tools
- makedepends = extra-cmake-modules
makedepends = libxrandr
+ makedepends = extra-cmake-modules
depends = qt5-base
depends = qt5-svg
depends = qt5-x11extras
- depends = optimus-manager>=1.3
- source = optimus-manager-qt-1.5.3.tar.gz::https://github.com/Shatur95/optimus-manager-qt/archive/1.5.3.tar.gz
- source = SingleApplication-3.1.3.1.tar.gz::https://github.com/itay-grudev/SingleApplication/archive/v3.1.3.1.tar.gz
- sha256sums = 7e28acb2d4668fddf660a975129750157215e31732dc38390a519ac800f21496
- sha256sums = bbc20faa3e914cda8fe94b5d0bf98af640d3298a791a16cad4571a9ccbf1d030
+ depends = optimus-manager>=1.4
+ source = optimus-manager-qt-1.6.0.tar.gz::https://github.com/Shatur95/optimus-manager-qt/archive/1.6.0.tar.gz
+ sha256sums = 13e627617087845b81ca4ecd19cbbda7393d5bd823a77b7115f34fa4282991a9
pkgname = optimus-manager-qt
diff --git a/PKGBUILD b/PKGBUILD
index ecaad4a18fc8..7fa86eb0cfd5 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,42 +1,32 @@
# Maintainer: Shatur <genaloner@gmail.com>
# Use KDE API features (recommended for Plasma users)
-_plasma=false
-
-# Submodule versions
-_singleapplication=3.1.3.1
+_with_plasma=false
pkgname=optimus-manager-qt
-pkgver=1.5.3
+pkgver=1.6.0
pkgrel=1
pkgdesc='A Qt interface for Optimus Manager that allows to configure and switch GPUs on Optimus laptops using the tray menu'
arch=(x86_64)
url=https://github.com/Shatur95/optimus-manager-qt
license=(GPL3)
-depends=(qt5-base qt5-svg qt5-x11extras 'optimus-manager>=1.3')
-makedepends=(qt5-tools extra-cmake-modules libxrandr)
-source=($pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz
- SingleApplication-$_singleapplication.tar.gz::https://github.com/itay-grudev/SingleApplication/archive/v$_singleapplication.tar.gz)
-sha256sums=(7e28acb2d4668fddf660a975129750157215e31732dc38390a519ac800f21496
- bbc20faa3e914cda8fe94b5d0bf98af640d3298a791a16cad4571a9ccbf1d030)
-
-if [ $_plasma == true ]
+depends=(qt5-base qt5-svg qt5-x11extras 'optimus-manager>=1.4')
+makedepends=(qt5-tools libxrandr extra-cmake-modules)
+source=($pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz)
+sha256sums=(13e627617087845b81ca4ecd19cbbda7393d5bd823a77b7115f34fa4282991a9)
+
+if [ $_with_plasma == true ]
then
depends+=(knotifications kiconthemes)
fi
-# Move submodules into the project
-prepare() {
- mv SingleApplication-$_singleapplication/* $pkgname-$pkgver/src/third-party/singleapplication
-}
-
build() {
mkdir -p $pkgname-$pkgver/build
cd $pkgname-$pkgver/build
- if [ $_plasma == true ]
+ if [ $_with_plasma == true ]
then
- cmake -D CMAKE_INSTALL_PREFIX="$pkgdir/usr" -D PLASMA=ON ..
+ cmake -D CMAKE_INSTALL_PREFIX="$pkgdir/usr" -D WITH_PLASMA=ON ..
else
cmake -D CMAKE_INSTALL_PREFIX="$pkgdir/usr" ..
fi