summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShatur952019-02-27 12:13:19 +0200
committerShatur952019-02-27 12:13:19 +0200
commit361a0b36f4c0089bb01f384ea3ee8b816c62380e (patch)
tree6ed63b44565dcd1a717d736fc87ef5c65e9c0854
downloadaur-361a0b36f4c0089bb01f384ea3ee8b816c62380e.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rwxr-xr-xPKGBUILD44
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2230c65733db
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = optimus-manager-qt
+ pkgdesc = A Qt interface for Optimus Manager that allows to configure and switch GPUs on Optimus laptops using the tray menu
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/Shatur95/optimus-manager-qt
+ arch = x86_64
+ license = GPL3
+ makedepends = qt5-tools
+ depends = qt5-base
+ depends = optimus-manager
+ source = optimus-manager-qt.tar.gz::https://github.com/Shatur95/optimus-manager-qt/archive/1.0.0.tar.gz
+ source = SingleApplication-submodule.tar.gz::https://github.com/itay-grudev/SingleApplication/archive/3.0.14.tar.gz
+ sha256sums = 45e8247ceb924a56371377e1ccdb5a89de0ed90a115c53326d27ecefbdca2646
+ sha256sums = 898aa58cebceb07a3b9af65011c0eef23e9789f930a021037dd7e05d2910f318
+
+pkgname = optimus-manager-qt
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..deeedb49bf3f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Shatur <genaloner@gmail.com>
+
+# Use KDE API for tray for additional feautures (this also add knotifier dependency, recommended for KDE users).
+KDE=false
+
+pkgname=optimus-manager-qt
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="A Qt interface for Optimus Manager that allows to configure and switch GPUs on Optimus laptops using the tray menu"
+arch=('x86_64')
+url="https://github.com/Shatur95/optimus-manager-qt"
+license=('GPL3')
+depends=('qt5-base' 'optimus-manager')
+makedepends=('qt5-tools')
+source=($pkgname.tar.gz::"https://github.com/Shatur95/optimus-manager-qt/archive/$pkgver.tar.gz"
+ SingleApplication-submodule.tar.gz::"https://github.com/itay-grudev/SingleApplication/archive/3.0.14.tar.gz")
+sha256sums=('45e8247ceb924a56371377e1ccdb5a89de0ed90a115c53326d27ecefbdca2646'
+ '898aa58cebceb07a3b9af65011c0eef23e9789f930a021037dd7e05d2910f318')
+
+if [ ${KDE} == true ]; then
+ depends+=('knotifications')
+fi
+
+# Move submodules into the project
+prepare() {
+ mv SingleApplication-3.0.14/* "$pkgname-$pkgver/src/third-party/singleapplication"
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+
+ if [ ${KDE} == true ]; then
+ qmake "DEFINES += KDE"
+ else
+ qmake
+ fi
+
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make INSTALL_ROOT="$pkgdir/" install
+}