summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShatur952020-05-16 21:26:09 +0300
committerShatur952020-05-16 21:26:09 +0300
commit4e204a8663ce1902efd0d6d9b3974abcda3df6d7 (patch)
tree18e19cbe243bc26a38505beb1f4b7f4b660f1e06
parent679b088d6825ae5050e6756c800c61db771d70ab (diff)
downloadaur-4e204a8663ce1902efd0d6d9b3974abcda3df6d7.tar.gz
Update to 1.5.1
-rwxr-xr-x.SRCINFO11
-rwxr-xr-xPKGBUILD27
2 files changed, 20 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 23e5df7d808a..5fc7ecfc019f 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,21 @@
pkgbase = optimus-manager-qt
pkgdesc = A Qt interface for Optimus Manager that allows to configure and switch GPUs on Optimus laptops using the tray menu
- pkgver = 1.5.0
+ pkgver = 1.5.1
pkgrel = 1
url = https://github.com/Shatur95/optimus-manager-qt
arch = x86_64
license = GPL3
makedepends = qt5-tools
+ makedepends = extra-cmake-modules
makedepends = libxrandr
depends = qt5-base
depends = qt5-svg
depends = qt5-x11extras
depends = optimus-manager>=1.3
- source = optimus-manager-qt-1.5.0.tar.gz::https://github.com/Shatur95/optimus-manager-qt/archive/1.5.0.tar.gz
- source = SingleApplication-3.0.19.tar.gz::https://github.com/itay-grudev/SingleApplication/archive/v3.0.19.tar.gz
- sha256sums = 5e1c81b5e0291b69e16a23c4f681031aa77312885d0649d548e80874c33e9a23
- sha256sums = 9405fd259288b2a862e91e5135bccee936f0438e1b32c13603277132309d15e0
+ source = optimus-manager-qt-1.5.1.tar.gz::https://github.com/Shatur95/optimus-manager-qt/archive/1.5.1.tar.gz
+ source = SingleApplication-3.1.3.tar.gz::https://github.com/itay-grudev/SingleApplication/archive/v3.1.3.tar.gz
+ sha256sums = 3067d6dad33bdaf838eec01b1f5c02f9a2b4897e0e7304ca2a0a1bed6f7e7bd8
+ sha256sums = 4585f02fbfba61626e4ed4f1815b847c72f1593bffac6015f6e75f514094f148
pkgname = optimus-manager-qt
diff --git a/PKGBUILD b/PKGBUILD
index f224c3832592..83dc8ef764c7 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,21 +4,21 @@
_plasma=false
# Submodule versions
-_singleapplication=3.0.19
+_singleapplication=3.1.3
pkgname=optimus-manager-qt
-pkgver=1.5.0
+pkgver=1.5.1
pkgrel=1
pkgdesc='A Qt interface for Optimus Manager that allows to configure and switch GPUs on Optimus laptops using the tray menu'
arch=(x86_64)
url=https://github.com/Shatur95/optimus-manager-qt
license=(GPL3)
depends=(qt5-base qt5-svg qt5-x11extras 'optimus-manager>=1.3')
-makedepends=(qt5-tools libxrandr)
+makedepends=(qt5-tools extra-cmake-modules libxrandr)
source=($pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz
SingleApplication-$_singleapplication.tar.gz::https://github.com/itay-grudev/SingleApplication/archive/v$_singleapplication.tar.gz)
-sha256sums=(5e1c81b5e0291b69e16a23c4f681031aa77312885d0649d548e80874c33e9a23
- 9405fd259288b2a862e91e5135bccee936f0438e1b32c13603277132309d15e0)
+sha256sums=(3067d6dad33bdaf838eec01b1f5c02f9a2b4897e0e7304ca2a0a1bed6f7e7bd8
+ 4585f02fbfba61626e4ed4f1815b847c72f1593bffac6015f6e75f514094f148)
if [ $_plasma == true ]
then
@@ -31,19 +31,20 @@ prepare() {
}
build() {
- cd $pkgname-$pkgver
-
+ mkdir -p $pkgname-$pkgver/build
+ cd $pkgname-$pkgver/build
+
if [ $_plasma == true ]
then
- qmake "DEFINES += PLASMA"
+ cmake -D CMAKE_INSTALL_PREFIX="$pkgdir/usr" -D PLASMA=ON ..
else
- qmake
+ cmake -D CMAKE_INSTALL_PREFIX="$pkgdir/usr" ..
fi
- make
+ cmake --build .
}
package() {
- cd $pkgname-$pkgver
- make INSTALL_ROOT="$pkgdir/" install
-}
+ cd $pkgname-$pkgver/build
+ cmake --install .
+}