summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShatur952019-03-26 18:31:37 +0200
committerShatur952019-03-26 18:31:37 +0200
commiteeede1fdf13da1cc9fd71a7e7106f75caaf06b53 (patch)
tree44a43919dce7f88aebd574b7fcc6dcf3ff6eba7c
parent361a0b36f4c0089bb01f384ea3ee8b816c62380e (diff)
downloadaur-eeede1fdf13da1cc9fd71a7e7106f75caaf06b53.tar.gz
Update to 1.1.0
-rwxr-xr-x[-rw-r--r--].SRCINFO8
-rwxr-xr-xPKGBUILD18
2 files changed, 13 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2230c65733db..ec33ae392900 100644..100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = optimus-manager-qt
pkgdesc = A Qt interface for Optimus Manager that allows to configure and switch GPUs on Optimus laptops using the tray menu
- pkgver = 1.0.0
+ pkgver = 1.1.0
pkgrel = 1
url = https://github.com/Shatur95/optimus-manager-qt
arch = x86_64
license = GPL3
makedepends = qt5-tools
depends = qt5-base
- depends = optimus-manager
- source = optimus-manager-qt.tar.gz::https://github.com/Shatur95/optimus-manager-qt/archive/1.0.0.tar.gz
+ depends = optimus-manager>=0.8
+ source = optimus-manager-qt.tar.gz::https://github.com/Shatur95/optimus-manager-qt/archive/1.1.0.tar.gz
source = SingleApplication-submodule.tar.gz::https://github.com/itay-grudev/SingleApplication/archive/3.0.14.tar.gz
- sha256sums = 45e8247ceb924a56371377e1ccdb5a89de0ed90a115c53326d27ecefbdca2646
+ sha256sums = d6864b150280dc80b9f06f2b52d615e946adcc870b8461f3204eb11c09398187
sha256sums = 898aa58cebceb07a3b9af65011c0eef23e9789f930a021037dd7e05d2910f318
pkgname = optimus-manager-qt
diff --git a/PKGBUILD b/PKGBUILD
index deeedb49bf3f..82d8d95b156f 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,24 @@
# Maintainer: Shatur <genaloner@gmail.com>
-# Use KDE API for tray for additional feautures (this also add knotifier dependency, recommended for KDE users).
-KDE=false
+# Use KDE API features (recommended for Plasma users)
+PLASMA=false
pkgname=optimus-manager-qt
-pkgver=1.0.0
+pkgver=1.1.0
pkgrel=1
pkgdesc="A Qt interface for Optimus Manager that allows to configure and switch GPUs on Optimus laptops using the tray menu"
arch=('x86_64')
url="https://github.com/Shatur95/optimus-manager-qt"
license=('GPL3')
-depends=('qt5-base' 'optimus-manager')
+depends=('qt5-base' 'optimus-manager>=0.8')
makedepends=('qt5-tools')
source=($pkgname.tar.gz::"https://github.com/Shatur95/optimus-manager-qt/archive/$pkgver.tar.gz"
SingleApplication-submodule.tar.gz::"https://github.com/itay-grudev/SingleApplication/archive/3.0.14.tar.gz")
-sha256sums=('45e8247ceb924a56371377e1ccdb5a89de0ed90a115c53326d27ecefbdca2646'
+sha256sums=('d6864b150280dc80b9f06f2b52d615e946adcc870b8461f3204eb11c09398187'
'898aa58cebceb07a3b9af65011c0eef23e9789f930a021037dd7e05d2910f318')
-if [ ${KDE} == true ]; then
- depends+=('knotifications')
+if [ ${PLASMA} == true ]; then
+ depends+=('knotifications' 'kiconthemes')
fi
# Move submodules into the project
@@ -29,8 +29,8 @@ prepare() {
build() {
cd "$pkgname-$pkgver"
- if [ ${KDE} == true ]; then
- qmake "DEFINES += KDE"
+ if [ ${PLASMA} == true ]; then
+ qmake "DEFINES += PLASMA"
else
qmake
fi