summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShatur952020-10-12 23:41:08 +0300
committerShatur952020-10-12 23:41:08 +0300
commit37c357d84cfc4ba38fe54aec188ff8cb6da9b79b (patch)
tree2cceac363a6871f19c47ad301cc9773df235fe10
parentd2ebafaa9f28c45e24ecb6e3ae672fe8aa060f31 (diff)
downloadaur-37c357d84cfc4ba38fe54aec188ff8cb6da9b79b.tar.gz
Update build rules
-rwxr-xr-x.SRCINFO2
-rwxr-xr-xPKGBUILD18
2 files changed, 6 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e76638243803..c14a29725274 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = optimus-manager-qt-git
pkgdesc = A Qt interface for Optimus Manager that allows to configure and switch GPUs on Optimus laptops using the tray menu
- pkgver = 1.5.1.r6.g7eb0c9f
+ pkgver = 1.5.3.r19.g51a67d8
pkgrel = 1
url = https://github.com/Shatur95/optimus-manager-qt
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 2fb99c0b6d1d..c688681e85d9 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,10 @@
# Maintainer: Shatur <genaloner@gmail.com>
# Use KDE API features (recommended for Plasma users)
-_plasma=false
+_with_plasma=false
pkgname=optimus-manager-qt-git
-pkgver=1.5.1.r6.g7eb0c9f
+pkgver=1.5.3.r19.g51a67d8
pkgrel=1
pkgdesc='A Qt interface for Optimus Manager that allows to configure and switch GPUs on Optimus laptops using the tray menu'
arch=(x86_64)
@@ -17,7 +17,7 @@ conflicts=(${pkgname%-git})
source=(git+$url)
sha256sums=(SKIP)
-if [ $_plasma == true ]
+if [ $_with_plasma == true ]
then
depends+=(knotifications kiconthemes)
fi
@@ -27,21 +27,13 @@ pkgver() {
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
-# Clone submodules
-prepare() {
- cd ${pkgname%-git}
-
- git submodule init
- git submodule update
-}
-
build() {
mkdir -p ${pkgname%-git}/build
cd ${pkgname%-git}/build
- if [ $_plasma == true ]
+ if [ $_with_plasma == true ]
then
- cmake -D CMAKE_INSTALL_PREFIX="$pkgdir/usr" -D PLASMA=ON ..
+ cmake -D CMAKE_INSTALL_PREFIX="$pkgdir/usr" -D WITH_PLASMA=ON ..
else
cmake -D CMAKE_INSTALL_PREFIX="$pkgdir/usr" ..
fi