summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShatur952020-05-16 21:15:01 +0300
committerShatur952020-05-16 21:15:04 +0300
commit5852c8736dc26276110539ecb5c7b45d06999cd1 (patch)
treefbf8f9d9dbe47f7f9a477ff1399c3b74e3011c8b
parentd2b4c62d11b9431b3a185ddab3f48885032d00a4 (diff)
downloadaur-5852c8736dc26276110539ecb5c7b45d06999cd1.tar.gz
Fix PLASMA option syntax
-rwxr-xr-x.SRCINFO7
-rwxr-xr-xPKGBUILD8
2 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ccb2da3a56db..f52677e332a5 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,20 @@
pkgbase = optimus-manager-qt-git
pkgdesc = A Qt interface for Optimus Manager that allows to configure and switch GPUs on Optimus laptops using the tray menu
- pkgver = 1.5.0.r2.g849bfd5
+ pkgver = 1.5.1.r1.gbb1acd9
pkgrel = 1
url = https://github.com/Shatur95/optimus-manager-qt
arch = x86_64
license = GPL3
makedepends = qt5-tools
makedepends = libxrandr
- makedepends = git
- makedepends = cmake
makedepends = extra-cmake-modules
+ makedepends = git
depends = qt5-base
depends = qt5-svg
depends = qt5-x11extras
depends = optimus-manager
+ depends = knotifications
+ depends = kiconthemes
provides = optimus-manager-qt
conflicts = optimus-manager-qt
source = git+https://github.com/Shatur95/optimus-manager-qt
diff --git a/PKGBUILD b/PKGBUILD
index f9dbb9e61eb9..dd7cd02dfe19 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
# Maintainer: Shatur <genaloner@gmail.com>
# Use KDE API features (recommended for Plasma users)
-_plasma=false
+_plasma=true
pkgname=optimus-manager-qt-git
-pkgver=1.5.0.r2.g849bfd5
+pkgver=1.5.1.r1.gbb1acd9
pkgrel=1
pkgdesc='A Qt interface for Optimus Manager that allows to configure and switch GPUs on Optimus laptops using the tray menu'
arch=(x86_64)
url=https://github.com/Shatur95/optimus-manager-qt
license=(GPL3)
depends=(qt5-base qt5-svg qt5-x11extras optimus-manager)
-makedepends=(qt5-tools libxrandr git cmake extra-cmake-modules)
+makedepends=(qt5-tools libxrandr extra-cmake-modules git)
provides=(${pkgname%-git})
conflicts=(${pkgname%-git})
source=(git+$url)
@@ -41,7 +41,7 @@ build() {
if [ $_plasma == true ]
then
- cmake -D CMAKE_INSTALL_PREFIX="$pkgdir/usr" -D PLASMA ..
+ cmake -D CMAKE_INSTALL_PREFIX="$pkgdir/usr" -D PLASMA=ON ..
else
cmake -D CMAKE_INSTALL_PREFIX="$pkgdir/usr" ..
fi