summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShatur952019-09-21 13:53:16 +0300
committerShatur952019-09-21 13:53:16 +0300
commitb46980fa53ed8ccc520effa0e3e1a6aba0b6c8f1 (patch)
treec44fa911346f5a80b13e0d7b8519732ef5548332
parentc1420620acecce78e1c70d205c48a2c7fc9d349a (diff)
downloadaur-b46980fa53ed8ccc520effa0e3e1a6aba0b6c8f1.tar.gz
Refactor PKGBUILD
-rwxr-xr-xPKGBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 340fbf003ce6..c88b4357d32f 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
_plasma=false
pkgname=optimus-manager-qt-git
-pkgver=1.2.0.r0.ge25f2ce
+pkgver=1.3.0.r0.gdf1fa13
pkgrel=1
pkgdesc="A Qt interface for Optimus Manager that allows to configure and switch GPUs on Optimus laptops using the tray menu"
arch=('x86_64')
@@ -17,7 +17,8 @@ conflicts=("${pkgname%-git}")
source=("git+https://github.com/Shatur95/optimus-manager-qt")
sha256sums=('SKIP')
-if [ $_plasma == true ]; then
+if [ $_plasma == true ]
+then
depends+=('knotifications' 'kiconthemes')
fi
@@ -37,7 +38,8 @@ prepare() {
build() {
cd "${pkgname%-git}"
- if [ $_plasma == true ]; then
+ if [ $_plasma == true ]
+ then
qmake "DEFINES += PLASMA"
else
qmake