summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShatur952020-05-16 15:29:19 +0300
committerShatur952020-05-16 20:08:04 +0300
commitd2b4c62d11b9431b3a185ddab3f48885032d00a4 (patch)
tree1e3deaebed9eca297e87ba0f33b93a336b134ebb
parentf5fbb8f3f0593436fd5e3729b182f78d8345a5b8 (diff)
downloadaur-d2b4c62d11b9431b3a185ddab3f48885032d00a4.tar.gz
Switch to CMake
-rwxr-xr-x.SRCINFO4
-rwxr-xr-xPKGBUILD17
2 files changed, 12 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 96adb38575bb..ccb2da3a56db 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = optimus-manager-qt-git
pkgdesc = A Qt interface for Optimus Manager that allows to configure and switch GPUs on Optimus laptops using the tray menu
- pkgver = 1.4.5.r11.g23e75f6
+ pkgver = 1.5.0.r2.g849bfd5
pkgrel = 1
url = https://github.com/Shatur95/optimus-manager-qt
arch = x86_64
@@ -8,6 +8,8 @@ pkgbase = optimus-manager-qt-git
makedepends = qt5-tools
makedepends = libxrandr
makedepends = git
+ makedepends = cmake
+ makedepends = extra-cmake-modules
depends = qt5-base
depends = qt5-svg
depends = qt5-x11extras
diff --git a/PKGBUILD b/PKGBUILD
index 59a3ef012b01..f9dbb9e61eb9 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,14 +4,14 @@
_plasma=false
pkgname=optimus-manager-qt-git
-pkgver=1.4.5.r11.g23e75f6
+pkgver=1.5.0.r2.g849bfd5
pkgrel=1
pkgdesc='A Qt interface for Optimus Manager that allows to configure and switch GPUs on Optimus laptops using the tray menu'
arch=(x86_64)
url=https://github.com/Shatur95/optimus-manager-qt
license=(GPL3)
depends=(qt5-base qt5-svg qt5-x11extras optimus-manager)
-makedepends=(qt5-tools libxrandr git)
+makedepends=(qt5-tools libxrandr git cmake extra-cmake-modules)
provides=(${pkgname%-git})
conflicts=(${pkgname%-git})
source=(git+$url)
@@ -36,20 +36,21 @@ prepare() {
}
build() {
- cd ${pkgname%-git}
+ mkdir -p ${pkgname%-git}/build
+ cd ${pkgname%-git}/build
if [ $_plasma == true ]
then
- qmake "DEFINES += PLASMA"
+ cmake -D CMAKE_INSTALL_PREFIX="$pkgdir/usr" -D PLASMA ..
else
- qmake
+ cmake -D CMAKE_INSTALL_PREFIX="$pkgdir/usr" ..
fi
- make
+ cmake --build .
}
package() {
- cd ${pkgname%-git}
+ cd ${pkgname%-git}/build
- make INSTALL_ROOT="$pkgdir/" install
+ cmake --install .
}