summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryvbbrjdr2020-07-21 22:15:59 -0700
committeryvbbrjdr2020-07-21 22:15:59 -0700
commitb166fad59483c0be324e58784c9942022cc8baab (patch)
tree48d99fda293edae50b10a7de913d641cae2f7164
parentc1e73c646d2ab4fa6db65a2e38e3426f850a3a62 (diff)
downloadaur-b166fad59483c0be324e58784c9942022cc8baab.tar.gz
change cmake path
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
-rw-r--r--cmake.patch11
3 files changed, 20 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2f72dd68d564..e1d2f4d6814c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,16 @@
pkgbase = optix
pkgdesc = A software development kit for achieving high performance ray tracing on the GPU.
pkgver = 7.1.0
- pkgrel = 1
+ pkgrel = 2
url = https://developer.nvidia.com/optix
arch = x86_64
license = custom:NVIDIA
depends = cuda
options = !strip
source = file://NVIDIA-OptiX-SDK-7.1.0-linux64-x86_64.sh
+ source = file://cmake.patch
sha512sums = 808a45e2007d8081de21fe15cad4577ba9fe10fc3612486b1230e03b7f17de91902dc773d1f3fef2b89398f230448d9522a03e19d4e6fa12aa4ffd78f1a4f9dc
+ sha512sums = c2b3f122bf4e5d1bd987c3ce9693b24d2acd55f71f7366e49ebc0ba2f800945e6ddde439428761c6c12ec77f34a9334fb6900af2c1b10c40dd2905bb58c9ded2
pkgname = optix
diff --git a/PKGBUILD b/PKGBUILD
index 87c901f76e02..d0b65d87c459 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=optix
pkgver=7.1.0
-pkgrel=1
+pkgrel=2
pkgdesc="A software development kit for achieving high performance ray tracing on the GPU."
arch=('x86_64')
url="https://developer.nvidia.com/optix"
@@ -10,8 +10,10 @@ license=('custom:NVIDIA')
depends=('cuda')
options=(!strip)
_script="NVIDIA-OptiX-SDK-$pkgver-linux64-x86_64.sh"
-source=("file://$_script")
-sha512sums=('808a45e2007d8081de21fe15cad4577ba9fe10fc3612486b1230e03b7f17de91902dc773d1f3fef2b89398f230448d9522a03e19d4e6fa12aa4ffd78f1a4f9dc')
+source=("file://$_script"
+ "file://cmake.patch")
+sha512sums=('808a45e2007d8081de21fe15cad4577ba9fe10fc3612486b1230e03b7f17de91902dc773d1f3fef2b89398f230448d9522a03e19d4e6fa12aa4ffd78f1a4f9dc'
+ 'c2b3f122bf4e5d1bd987c3ce9693b24d2acd55f71f7366e49ebc0ba2f800945e6ddde439428761c6c12ec77f34a9334fb6900af2c1b10c40dd2905bb58c9ded2')
if ! [ -f $_script ]; then
msg2 "Please manually download $_script to $PWD from https://developer.nvidia.com/designworks/optix/download."
@@ -21,6 +23,7 @@ fi
package() {
mkdir -p "$pkgdir/opt/optix"
sh "$srcdir/$_script" --prefix="$pkgdir/opt/optix" --exclude-subdir --skip-license
+ patch "$pkgdir/opt/optix/SDK/CMake/FindOptiX.cmake" "$srcdir/cmake.patch"
mkdir -p "$pkgdir/usr/share/licenses/$pkgname"
ln -s /opt/optix/doc/OptiX_EndUserLicense.pdf "$pkgdir/usr/share/licenses/$pkgname/OptiX_EndUserLicense.pdf"
}
diff --git a/cmake.patch b/cmake.patch
new file mode 100644
index 000000000000..784b13d8e9b5
--- /dev/null
+++ b/cmake.patch
@@ -0,0 +1,11 @@
+--- FindOptiX.cmake.orig 2020-07-21 22:03:18.448748912 -0700
++++ FindOptiX.cmake.new 2020-07-21 22:03:36.353142082 -0700
+@@ -29,7 +29,7 @@
+ # Locate the OptiX distribution. Search relative to the SDK first, then look in the system.
+
+ # Our initial guess will be within the SDK.
+-set(OptiX_INSTALL_DIR "${CMAKE_SOURCE_DIR}/../" CACHE PATH "Path to OptiX installed location.")
++set(OptiX_INSTALL_DIR "${CMAKE_SOURCE_DIR}/../../" CACHE PATH "Path to OptiX installed location.")
+
+ # The distribution contains only 64 bit libraries. Error when we have been mis-configured.
+ if(NOT CMAKE_SIZEOF_VOID_P EQUAL 8)