summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle2015-07-28 20:36:13 -0400
committerKyle2015-07-28 20:36:13 -0400
commitd97b8855c7fc2554c6b0f004a7a191beb4778a47 (patch)
tree927352c7bbb395ebc423ee5932b3f4df38ef584b
downloadaur-d97b8855c7fc2554c6b0f004a7a191beb4778a47.tar.gz
Initial AUR4 import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD35
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..44fb61767a52
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = opus-tools-git
+ pkgdesc = A collection of tools for working with opus files (git version)
+ pkgver = 0.0
+ pkgrel = 2
+ url = http://wiki.xiph.org/Opus-tools
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = git
+ depends = opus
+ depends = libogg
+ provides = opus-tools
+ conflicts = opus-tools
+ source = git://git.xiph.org/opus-tools.git
+ md5sums = SKIP
+
+pkgname = opus-tools-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..17550596a425
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Kyle <kyle@gmx.ca>
+pkgname=opus-tools-git
+_gitname=opus-tools
+pkgver=0.0 # determined from git origin
+pkgrel=2
+pkgdesc="A collection of tools for working with opus files (git version)"
+arch=(i686 x86_64)
+url="http://wiki.xiph.org/Opus-tools"
+license=('BSD')
+depends=(opus libogg)
+makedepends=('git')
+provides=(opus-tools)
+conflicts=(opus-tools)
+source=('git://git.xiph.org/opus-tools.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd $_gitname
+ # Use the tag of the last commit
+ git describe --always | sed -e 's|v||' -e 's|-|.|g'
+}
+
+build() {
+ cd $_gitname
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd $_gitname
+ make DESTDIR="$pkgdir/" install
+}
+
+# vim:set ts=2 sw=2 et: