summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12017-08-21 15:43:49 +0800
committerChocobo12017-08-21 15:53:16 +0800
commit0ebdbaf1aefae6d84b56f361a734c741a1b03afa (patch)
treeb65f887b8bce7bd6a0798c973792bf32aa0a2d75
downloadaur-0ebdbaf1aefae6d84b56f361a734c741a1b03afa.tar.gz
newpkg: opusfile-git 0.9.r0.g2c239eb-1
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD40
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6c8b147f11e8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = opusfile-git
+ pkgdesc = Stand-alone decoder library for .opus streams
+ pkgver = 0.9.r0.g2c239eb
+ pkgrel = 1
+ url = https://opus-codec.org/
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = git
+ depends = glibc
+ depends = openssl
+ depends = opus
+ provides = opusfile
+ conflicts = opusfile
+ options = staticlibs
+ source = git+https://git.xiph.org/opusfile.git
+ sha256sums = SKIP
+
+pkgname = opusfile-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..72c0bb993c9a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=opusfile-git
+pkgver=0.9.r0.g2c239eb
+pkgrel=1
+pkgdesc="Stand-alone decoder library for .opus streams"
+arch=('i686' 'x86_64')
+url="https://opus-codec.org/"
+license=('BSD')
+depends=('glibc' 'openssl' 'opus')
+makedepends=('git')
+provides=('opusfile')
+conflicts=('opusfile')
+options=('staticlibs')
+source=("git+https://git.xiph.org/opusfile.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "opusfile"
+
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "opusfile"
+
+ ./autogen.sh
+ ./configure --prefix="/usr"
+ make
+}
+
+package() {
+ cd "opusfile"
+
+ make DESTDIR="$pkgdir" install
+
+ install -Dm644 "COPYING" "$pkgdir/usr/share/licenses/opusfile/COPYING"
+ rm "$pkgdir/usr/share/doc/opusfile/COPYING"
+}