summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGeorge Dietrich2021-07-31 16:10:57 -0400
committerGeorge Dietrich2021-07-31 16:10:57 -0400
commit46d4aea57f1d231603446252f2c1f85ae411a8ad (patch)
treec9c32c9a0654b3e53cc5d61eb573898aa146fe9e
downloadaur-46d4aea57f1d231603446252f2c1f85ae411a8ad.tar.gz
Add oq
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD30
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9f6aed6f34b1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = oq
+ pkgdesc = A performant, and portable jq wrapper to facilitate the consumption and output of formats other than JSON; using jq filters to transform the data.
+ pkgver = 1.2.1
+ pkgrel = 1
+ url = https://github.com/blacksmoke16/oq
+ arch = i686
+ arch = x86_64
+ license = MIT
+ checkdepends = jq
+ checkdepends = crystal
+ makedepends = crystal
+ makedepends = shards
+ depends = jq
+ depends = libyaml
+ depends = libxml2
+ depends = libevent
+ depends = gc
+ depends = pcre
+ source = oq-1.2.1::https://github.com/blacksmoke16/oq/archive/v1.2.1.tar.gz
+ sha256sums = dc71c2662aa67a74add7331b5275dbce2c52adcab88767d356bcdd96f4e73b46
+
+pkgname = oq
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..66f23ce8548e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: George Dietrich <george@dietrich.app>
+pkgname=oq
+pkgver=1.2.1
+pkgrel=1
+pkgdesc='A performant, and portable jq wrapper to facilitate the consumption and output of formats other than JSON; using jq filters to transform the data.'
+arch=('i686' 'x86_64')
+url='https://github.com/blacksmoke16/oq'
+license=('MIT')
+depends=('jq' 'libyaml' 'libxml2' 'libevent' 'gc' 'pcre')
+makedepends=('crystal' 'shards')
+checkdepends=('jq' 'crystal')
+source=("$pkgname-$pkgver::$url/archive/v$pkgver.tar.gz")
+sha256sums=('dc71c2662aa67a74add7331b5275dbce2c52adcab88767d356bcdd96f4e73b46')
+
+build() {
+ cd "$pkgname-$pkgver"
+ shards build --release --no-debug --production --link-flags="-Wl,-z,relro,-z,now"
+}
+
+check() {
+ cd "$pkgname-$pkgver"
+ bin/oq -V
+ crystal spec --order random
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm755 bin/oq "$pkgdir/usr/bin/$pkgname"
+ install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}