summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Rogoża2017-10-12 22:21:23 +0200
committerPiotr Rogoża2017-10-12 22:21:23 +0200
commitdedcc598a0e3cfd0c227ea461159b5c80d16f92a (patch)
tree18a0e54a68856bc76bbaaf0f1c59dabe3e04e380
parent89e6a84628939073993fe94080861ad5a35d4b59 (diff)
downloadaur-dedcc598a0e3cfd0c227ea461159b5c80d16f92a.tar.gz
Upgraded to 3.0.1
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD15
-rwxr-xr-xoqapy.sh3
3 files changed, 20 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0516a5545bbd..70fe135bb15e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sun Sep 17 18:43:52 UTC 2017
+# Thu Oct 12 20:17:29 UTC 2017
pkgbase = oqapy
pkgdesc = An application intended to sort files of the image type in graphic mode.
- pkgver = 3.0.0
+ pkgver = 3.0.1
pkgrel = 1
url = http://www.oqapy.eu/
arch = any
@@ -16,8 +16,11 @@ pkgbase = oqapy
depends = gphoto2
depends = dcraw
depends = opencv
- source = http://www.oqapy.eu/releases/oqapy-3.0.0.tar.gz
- sha256sums = c0f5704ff520ea7457d9722a70a3f6127bed48c0bfbf3adf99840f7967950440
+ depends = hdf5
+ source = http://www.oqapy.eu/releases/oqapy-3.0.1.tar.gz
+ source = oqapy.sh
+ sha256sums = 6aed4929f7295d94da8f9770225424edd6f7d4ace97e76dd9209872830e0fd20
+ sha256sums = e5bd611647c50b21fb2b1f61801ee45172ee0aa052c3cf15e5e15cf8a0646a27
pkgname = oqapy
diff --git a/PKGBUILD b/PKGBUILD
index 345ab71b1595..5b59bffcb3e8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Huguenin Loïs <huguenindl at gmail dot com>
pkgname=oqapy
-pkgver=3.0.0
+pkgver=3.0.1
pkgrel=1
pkgdesc="An application intended to sort files of the image type in graphic mode."
arch=(any)
@@ -18,9 +18,11 @@ python-numpy
gphoto2
dcraw
opencv
+hdf5
)
-source=(http://www.oqapy.eu/releases/$pkgname-$pkgver.tar.gz)
-sha256sums=('c0f5704ff520ea7457d9722a70a3f6127bed48c0bfbf3adf99840f7967950440')
+source=(http://www.oqapy.eu/releases/$pkgname-$pkgver.tar.gz oqapy.sh)
+sha256sums=('6aed4929f7295d94da8f9770225424edd6f7d4ace97e76dd9209872830e0fd20'
+ 'e5bd611647c50b21fb2b1f61801ee45172ee0aa052c3cf15e5e15cf8a0646a27')
package() {
cd "$srcdir"/$pkgname-$pkgver
@@ -36,6 +38,9 @@ package() {
mv $pkgdir/usr/share/oqapy/oqapy.desktop $pkgdir/usr/share/applications/
install -Dm644 $pkgdir/usr/share/oqapy/medias/oqapy_ic_48.png \
"$pkgdir"/usr/share/pixmaps/
- cd "$pkgdir/usr/bin"
- ln -s /usr/share/oqapy/oqapy
+ # workaround for:
+ # Cannot decode file /usr/bin/tgz ...
+ install -Dm755 "$srcdir"/oqapy.sh "$pkgdir"/usr/bin/oqapy
+# cd "$pkgdir/usr/bin"
+# ln -s /usr/share/oqapy/oqapy
}
diff --git a/oqapy.sh b/oqapy.sh
new file mode 100755
index 000000000000..b6a057672e18
--- /dev/null
+++ b/oqapy.sh
@@ -0,0 +1,3 @@
+#!/usr/bin/env bash
+
+/usr/share/oqapy/oqapy "${@:-}"