summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAleksandar Trifunovic2022-12-03 21:04:46 +0100
committerAleksandar Trifunovic2022-12-03 21:04:46 +0100
commit19fe6206ac894fb82f00cc9738f5c3d196885359 (patch)
tree11fc5fffc483534e21bcb51cb111ced64a931434
parent9f105444d2ce7a6be486cf2b4eec29b56b6cf9bd (diff)
downloadaur-19fe6206ac894fb82f00cc9738f5c3d196885359.tar.gz
v9.5
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD33
2 files changed, 17 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 704682d7c1a4..6c295cd5fa6d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = or-tools
pkgdesc = Google's Operations Research tools.
- pkgver = 9.4
+ pkgver = 9.5
pkgrel = 1
url = https://github.com/google/or-tools
arch = x86_64
@@ -9,11 +9,11 @@ pkgbase = or-tools
makedepends = pkgconf
makedepends = git
makedepends = eigen
- makedepends = abseil-cpp
depends = coin-or-cbc
depends = protobuf
depends = re2
- source = https://github.com/google/or-tools/archive/v9.4.tar.gz
- sha256sums = 180fbc45f6e5ce5ff153bea2df0df59b15346f2a7f8ffbd7cb4aed0fb484b8f6
+ depends = abseil-cpp
+ source = or-tools-9.5.tar.gz::https://github.com/google/or-tools/archive/v9.5.tar.gz
+ sha256sums = 57f81b94949d35dc042690db3fa3f53245cffbf6824656e1a03f103a3623c939
pkgname = or-tools
diff --git a/PKGBUILD b/PKGBUILD
index 908bd6627be0..cd5beda81c9f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,19 @@
# Maintainer: Aleksandar Trifunović <akstrfn at gmail dot com>
pkgname=or-tools
-pkgver=9.4
+pkgver=9.5
pkgrel=1
pkgdesc="Google's Operations Research tools."
arch=('x86_64')
url="https://github.com/google/or-tools"
license=('Apache')
-depends=('coin-or-cbc' 'protobuf' 're2')
-# abseil fixed version since it breaks stuff
-makedepends=('cmake' 'pkgconf' 'git' 'eigen' 'abseil-cpp')
-source=("https://github.com/google/or-tools/archive/v${pkgver}.tar.gz")
-sha256sums=('180fbc45f6e5ce5ff153bea2df0df59b15346f2a7f8ffbd7cb4aed0fb484b8f6')
+depends=('coin-or-cbc' 'protobuf' 're2' 'abseil-cpp')
+makedepends=('cmake' 'pkgconf' 'git' 'eigen')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/google/or-tools/archive/v${pkgver}.tar.gz")
+sha256sums=('57f81b94949d35dc042690db3fa3f53245cffbf6824656e1a03f103a3623c939')
-prepare() {
- cd "$pkgname-$pkgver"
- cmake -S. -Bbuild \
+build() {
+ cmake -S "$pkgname-$pkgver" -B build \
-DCMAKE_C_FLAGS:STRING="${CFLAGS}" \
-DCMAKE_CXX_FLAGS:STRING="${CXXFLAGS}" \
-DCMAKE_EXE_LINKER_FLAGS:STRING="${LDFLAGS}" \
@@ -25,22 +23,17 @@ prepare() {
-DBUILD_DEPS=OFF \
-DUSE_SCIP=OFF \
-DBUILD_SAMPLES=OFF \
- -DBUILD_EXAMPLES=OFF
+ -DBUILD_EXAMPLES=ON
+ cmake --build build
}
-build() {
- cd "$pkgname-$pkgver/build"
- make
+# for testing, build examples
+check() {
+ ctest --test-dir build --output-on-failure --parallel `nproc`
}
-# for testing also build examples
-# check() {
-# cd "$pkgname-$pkgver/build"
-# ctest --parallel `nproc`
-# }
-
package() {
- cmake --build "$pkgname-$pkgver/build" -- DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" cmake --install build
install -d -m 755 "$pkgdir/usr/share/examples"
cp -a "$pkgname-$pkgver/examples/cpp" "$pkgdir/usr/share/examples/cpp"
}