summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAleksandar Trifunovic2019-03-02 10:11:48 +0100
committerAleksandar Trifunovic2019-03-02 10:11:48 +0100
commit4fe2e9b598e25e9690aedb60b9eee9549189273c (patch)
treed1b6e0345723b0b2f6f6b25627878326991f219a
parentd6a1f11a88aff616dd857e74f2228662343b332b (diff)
downloadaur-4fe2e9b598e25e9690aedb60b9eee9549189273c.tar.gz
add git to makedeps and move cmake config to prepare()
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD9
2 files changed, 7 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3afd1168d009..f9ce80ffa903 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = or-tools
pkgdesc = Google's Operations Research tools.
pkgver = 6.10
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/google/or-tools
arch = x86_64
license = Apache
diff --git a/PKGBUILD b/PKGBUILD
index 8e7a29b82451..6409ebd0fb76 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=or-tools
pkgver=6.10
-pkgrel=1
+pkgrel=2
pkgdesc="Google's Operations Research tools."
arch=('x86_64')
url="https://github.com/google/or-tools"
@@ -13,7 +13,7 @@ source=("https://github.com/google/or-tools/archive/v${pkgver}.tar.gz")
sha256sums=('d1131ca6d7c2388400493c774dfd0b5d5c270a8a9645391876400a194354cfd6')
conflicts=('python-or-tools') # because it copies libortools.so to usr/lib
-build() {
+prepare() {
cd "$pkgname-$pkgver"
cmake -H. -Bbuild \
-DCMAKE_C_FLAGS:STRING="${CFLAGS}" \
@@ -22,8 +22,11 @@ build() {
-DCMAKE_INSTALL_LIBDIR=lib \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=Release \
- -DBUILD_PYTHON=OFF \
+ -DBUILD_PYTHON=OFF
+}
+build() {
+ cd "$pkgname-$pkgver"
cmake --build build
}