summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAleksandar Trifunovic2021-12-19 23:14:24 +0100
committerAleksandar Trifunovic2021-12-19 23:14:24 +0100
commitee1a1262fb08590cfa4b9e0d5ed727fe8ec20d28 (patch)
tree4304b90c3f6dcaff593e239df929934410b25ea1
parent586779714f1b3eaad3db0c54c91adab85298190d (diff)
downloadaur-ee1a1262fb08590cfa4b9e0d5ed727fe8ec20d28.tar.gz
v9.2
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4999356c1e85..45bb4e8fc746 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = or-tools
pkgdesc = Google's Operations Research tools.
- pkgver = 9.1
+ pkgver = 9.2
pkgrel = 1
url = https://github.com/google/or-tools
arch = x86_64
@@ -8,10 +8,10 @@ pkgbase = or-tools
makedepends = cmake
makedepends = pkgconf
makedepends = git
- makedepends = abseil-cpp=20210324.2
+ makedepends = abseil-cpp=20211102.0
depends = coin-or-cbc
depends = protobuf
- source = https://github.com/google/or-tools/archive/v9.1.tar.gz
- sha256sums = b51ca3b08f768de5a0c1029f7127264640e50d9c7b83383a175109ef213bd307
+ source = https://github.com/google/or-tools/archive/v9.2.tar.gz
+ sha256sums = 5337935ea1fa010bb62cf0fc8bedd6de07dda77bff3db7a0f6a36c84c7bd58db
pkgname = or-tools
diff --git a/PKGBUILD b/PKGBUILD
index b2243827ba59..4151bec62be3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Aleksandar Trifunović <akstrfn at gmail dot com>
pkgname=or-tools
-pkgver=9.1
+pkgver=9.2
pkgrel=1
pkgdesc="Google's Operations Research tools."
arch=('x86_64')
@@ -9,9 +9,9 @@ url="https://github.com/google/or-tools"
license=('Apache')
depends=('coin-or-cbc' 'protobuf')
# abseil fixed version since it breaks stuff
-makedepends=('cmake' 'pkgconf' 'git' 'abseil-cpp=20210324.2')
+makedepends=('cmake' 'pkgconf' 'git' 'abseil-cpp=20211102.0')
source=("https://github.com/google/or-tools/archive/v${pkgver}.tar.gz")
-sha256sums=('b51ca3b08f768de5a0c1029f7127264640e50d9c7b83383a175109ef213bd307')
+sha256sums=('5337935ea1fa010bb62cf0fc8bedd6de07dda77bff3db7a0f6a36c84c7bd58db')
prepare() {
cd "$pkgname-$pkgver"
@@ -33,7 +33,6 @@ build() {
make
}
-# https://github.com/google/or-tools/issues/2395
# for testing also build examples
# check() {
# cd "$pkgname-$pkgver/build"
@@ -44,5 +43,4 @@ package() {
cmake --build "$pkgname-$pkgver/build" -- DESTDIR="$pkgdir" install
install -d -m 755 "$pkgdir/usr/share/examples"
cp -a "$pkgname-$pkgver/examples/cpp" "$pkgdir/usr/share/examples/cpp"
- rm "$pkgdir"/usr/share/examples/cpp/{BUILD,CMakeLists.txt}
}