summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdam Nielsen2020-04-30 12:48:57 +1000
committerAdam Nielsen2020-04-30 12:48:57 +1000
commitd66f07d5d9aca3b7dfb513df7d448e83958da8b6 (patch)
treef547b9701a256b1d21124c2653d53eb9ddd90c24
parent762a2f5c216cc21a40f0d44901a816c974d1329f (diff)
downloadaur-d66f07d5d9aca3b7dfb513df7d448e83958da8b6.tar.gz
Update to 19.6 and include direct download
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD24
2 files changed, 16 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 11ca1f86db81..8a8d4b7cf60e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,19 @@
pkgbase = oracle-instantclient-jdbc
pkgdesc = Additional support for XA, Internationalization, and RowSet operations under JDBC
- pkgver = 19.5.0.0.0
+ pkgver = 19.6.0.0.0
pkgrel = 1
url = http://www.oracle.com/technetwork/database/features/instant-client/
arch = x86_64
license = custom:OTN
- depends = oracle-instantclient-basic=19.5.0.0.0
+ depends = oracle-instantclient-basic=19.6.0.0.0
replaces = instantclient-jdbc
options = !strip
source = LICENSE
- source = manual://instantclient-jdbc-linux.x64-19.5.0.0.0dbru.zip
+ source = https://download.oracle.com/otn_software/linux/instantclient/19600/instantclient-jdbc-linux.x64-19.6.0.0.0dbru.zip
md5sums = 2d62e22e4f2d7e6d220fafde0f692a7d
- md5sums = a0ccc4a8490c97bb7e821c612add81e5
+ md5sums = babe1819533862dd474b26109d26230f
sha256sums = f904a30b07ddf7806a33620f93b94c3d315154d26a371ece48695bb3555064a2
- sha256sums = 415b0402089a140a2bb71b5908df03d66bd6de411205af1528b1f350403142ef
+ sha256sums = ecf4183a054ca7c3c70012fb7b2c68670ec2383e2218b5e1a87c8e9ca2fbf85d
pkgname = oracle-instantclient-jdbc
diff --git a/PKGBUILD b/PKGBUILD
index 1ddc5ca19fc0..b81d697b5d96 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,9 @@
_pkgname=instantclient-jdbc
pkgname=oracle-${_pkgname}
-pkgver=19.5.0.0.0
+pkgver=19.6.0.0.0
+_urlver=19600
+_unzippath=instantclient_19_6
pkgrel=1
pkgdesc="Additional support for XA, Internationalization, and RowSet operations under JDBC"
arch=('x86_64')
@@ -21,18 +23,14 @@ DLAGENTS+=('manual::/usr/bin/false');
# These are the only files we want to include in the source package
source=(LICENSE
- "manual://${_pkgname}-linux.x64-${pkgver}dbru.zip")
+ "https://download.oracle.com/otn_software/linux/instantclient/${_urlver}/${_pkgname}-linux.x64-${pkgver}dbru.zip")
md5sums=('2d62e22e4f2d7e6d220fafde0f692a7d'
- 'a0ccc4a8490c97bb7e821c612add81e5')
+ 'babe1819533862dd474b26109d26230f')
sha256sums=('f904a30b07ddf7806a33620f93b94c3d315154d26a371ece48695bb3555064a2'
- '415b0402089a140a2bb71b5908df03d66bd6de411205af1528b1f350403142ef')
+ 'ecf4183a054ca7c3c70012fb7b2c68670ec2383e2218b5e1a87c8e9ca2fbf85d')
-msg "Warning: This software cannot be downloaded automatically."
-plain "You will need to sign up for an Oracle account and download the software from"
-plain "Oracle directly. Place the downloaded file in the same directory as the"
-plain "PKGBUILD and re-run makepkg."
-plain ""
-plain "The source .zip files can be downloaded from:"
+plain "If you run into any problems downloading the files, get the .zip version from"
+plain "Oracle and place them in the PKGBUILD directory then re-run makepkg:"
plain ""
plain " http://www.oracle.com/technetwork/topics/linuxx86-64soft-092277.html"
plain ""
@@ -49,8 +47,8 @@ plain "[1]: http://www.oracle.com/technetwork/licenses/instant-client-lic-152016
plain ""
package() {
- local basedir="$srcdir/instantclient_19_5"
+ local basedir="$srcdir/${_unzippath}/"
install -d "$pkgdir/usr/lib"
- install -m 755 -t "$pkgdir/usr/lib" "$basedir/"*.so
- install -m 644 -t "$pkgdir/usr/lib" "$basedir/"*.jar
+ install -m 755 -t "$pkgdir/usr/lib" "$basedir"*.so
+ install -m 644 -t "$pkgdir/usr/lib" "$basedir"*.jar
}