summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author0b1001002022-03-17 19:39:57 +0100
committer0b1001002022-03-17 19:42:40 +0100
commit9ec7c10d575a949b91682e561903094268050af0 (patch)
tree3281b895934003570dbc23c388b74d88bf649f4a
downloadaur-9ec7c10d575a949b91682e561903094268050af0.tar.gz
Revive with version 4.16.0
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD33
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5c7e5f8cbe7c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = orage
+ pkgdesc = A simple calendar application with reminders for Xfce
+ pkgver = 4.16.0
+ pkgrel = 1
+ url = https://docs.xfce.org/apps/orage/start
+ arch = i686
+ arch = x86_64
+ groups = xfce4-goodies
+ license = GPL2
+ makedepends = xfce4-dev-tools
+ depends = xfce4-panel
+ depends = libnotify
+ depends = dbus-glib
+ depends = libical
+ source = https://archive.xfce.org/src/apps/orage/4.16/orage-4.16.0.tar.bz2
+ sha512sums = 00f5dd069a90f5398cc6789006ba503097b5246111f88e28952de4fe7927deba8e8cfb136ed1ebe8a90e1bd656116259204f25af852aa0e502be38f37459243b
+
+pkgname = orage
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1cd7b6763117
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: 0b100100 <0b100100 at protonmail dot ch>
+
+pkgname=orage
+pkgver=4.16.0
+pkgrel=1
+pkgdesc="A simple calendar application with reminders for Xfce"
+arch=("i686" "x86_64")
+license=('GPL2')
+url="https://docs.xfce.org/apps/orage/start"
+groups=('xfce4-goodies')
+depends=('xfce4-panel' 'libnotify' 'dbus-glib' 'libical')
+makedepends=('xfce4-dev-tools')
+source=("https://archive.xfce.org/src/apps/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.bz2")
+sha512sums=('00f5dd069a90f5398cc6789006ba503097b5246111f88e28952de4fe7927deba8e8cfb136ed1ebe8a90e1bd656116259204f25af852aa0e502be38f37459243b')
+
+build() {
+ cd "$pkgname-$pkgver"
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --libexecdir=/usr/lib/xfce4 \
+ --localstatedir=/var \
+ --disable-static \
+ --disable-debug
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}
+
+# vim:set ts=2 sw=2 et: