summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJason Papakostas2019-02-27 13:20:29 -0600
committerJason Papakostas2019-02-27 13:20:56 -0600
commit1cca626ee40d76faf1d70bf3428e6d892fb82ea1 (patch)
treeb91f3db3b7328cd1af4773b7ad265f4af682eda1
parent3becf16089870263f4193d627360a859b402586c (diff)
downloadaur-1cca626ee40d76faf1d70bf3428e6d892fb82ea1.tar.gz
re-export GOPATH in each relevant function
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD5
2 files changed, 4 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b0ec61e7a43f..b5323ba9dc34 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = oragono
pkgdesc = A modern IRC server written in Go.
pkgver = 1.0.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/oragono/oragono
install = install
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 5cffcf57340e..f8f358e3dfeb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=oragono
pkgver=1.0.0
-pkgrel=1
+pkgrel=2
pkgdesc="A modern IRC server written in Go."
arch=('x86_64')
url="https://github.com/oragono/oragono"
@@ -26,7 +26,6 @@ sha256sums=('SKIP'
backup=('etc/oragono.conf')
prepare() {
- export GOPATH=$(pwd)/..
cd "${srcdir}/$pkgname"
local _path=$(pwd)
git submodule init
@@ -41,6 +40,7 @@ prepare() {
}
build() {
+ export GOPATH=$(pwd)/..
cd "${srcdir}/$pkgname"
# flags from https://wiki.archlinux.org/index.php/Go_package_guidelines
@@ -60,6 +60,7 @@ build() {
}
check() {
+ export GOPATH=$(pwd)/..
cd "${srcdir}/$pkgname"
go test ./...