summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSean Enck2018-10-15 08:45:18 -0400
committerSean Enck2018-10-15 08:45:18 -0400
commit80e23e3c8c28e0a311ffcd2b4c7d0c40fa2e6317 (patch)
tree25c4286c7decc25983c67288adf7190f3ede1a6b
parente9290468eac4285790682f337228e374ff4754cb (diff)
downloadaur-80e23e3c8c28e0a311ffcd2b4c7d0c40fa2e6317.tar.gz
new version released
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD11
-rw-r--r--spaces-240.patch25
3 files changed, 7 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2e9d9ebae3c8..cfc5e514a78a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = oragono
pkgdesc = A modern IRC server written in Go.
- pkgver = 0.11.0
- pkgrel = 4
+ pkgver = 0.12.0
+ pkgrel = 1
url = https://github.com/oragono/oragono
install = install
arch = x86_64
@@ -10,20 +10,18 @@ pkgbase = oragono
makedepends = git
depends = glibc
backup = etc/oragono.conf
- source = git+https://github.com/oragono/oragono#tag=v0.11.0
+ source = git+https://github.com/oragono/oragono#tag=v0.12.0
source = git+https://github.com/oragono/oragono-vendor
source = oragono.service
source = oragono.sysusers
source = path.patch
source = oragono.tmpfiles
- source = spaces-240.patch
sha256sums = SKIP
sha256sums = SKIP
sha256sums = d35dd5205e3b607ee105a1252677d0607d0c35636ee3e6057275b5f13e555858
sha256sums = 7e214caa8bee053adac26a00a17ed732970e86665cbe31553b1d3d609f0a49b4
sha256sums = be7b802fa047c94e4b714a9232cccd2d8f5db356fefd4c01bc970d5be23d4943
sha256sums = d56a8935891bc421683e48245786c9f8d9d4c449197de5f455ce7d7804907c7a
- sha256sums = 21e9280caf4ddd4e940c49921a73b034b87d7c0dbfa4e8172a996df18853f63c
pkgname = oragono
diff --git a/PKGBUILD b/PKGBUILD
index 9d4a67205727..d8040e1ef79c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Sean Enck <enckse@gmail.com>
pkgname=oragono
-pkgver=0.11.0
-pkgrel=4
+pkgver=0.12.0
+pkgrel=1
pkgdesc="A modern IRC server written in Go."
arch=('x86_64')
url="https://github.com/oragono/oragono"
@@ -15,15 +15,13 @@ source=("git+$url#tag=v$pkgver"
"oragono.service"
"oragono.sysusers"
"path.patch"
- "oragono.tmpfiles"
- "spaces-240.patch")
+ "oragono.tmpfiles")
sha256sums=('SKIP'
'SKIP'
'd35dd5205e3b607ee105a1252677d0607d0c35636ee3e6057275b5f13e555858'
'7e214caa8bee053adac26a00a17ed732970e86665cbe31553b1d3d609f0a49b4'
'be7b802fa047c94e4b714a9232cccd2d8f5db356fefd4c01bc970d5be23d4943'
- 'd56a8935891bc421683e48245786c9f8d9d4c449197de5f455ce7d7804907c7a'
- '21e9280caf4ddd4e940c49921a73b034b87d7c0dbfa4e8172a996df18853f63c')
+ 'd56a8935891bc421683e48245786c9f8d9d4c449197de5f455ce7d7804907c7a')
backup=('etc/oragono.conf')
build() {
export GOPATH=$(pwd)/..
@@ -33,7 +31,6 @@ build() {
git config submodule.vendor.url "$srcdir"/oragono-vendor
git submodule update
patch -p1 < ../path.patch
- patch -p1 < ../spaces-240.patch
cd vendor/github.com/$pkgname
rm -rf $pkgname
mkdir -p $pkgname
diff --git a/spaces-240.patch b/spaces-240.patch
deleted file mode 100644
index e89ecd2fcd64..000000000000
--- a/spaces-240.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-diff --git a/irc/client.go b/irc/client.go
-index d309102..0cafce8 100644
---- a/irc/client.go
-+++ b/irc/client.go
-@@ -811,15 +811,15 @@ func (client *Client) SendRawMessage(message ircmsg.IrcMessage) error {
- message = ircmsg.MakeMessage(nil, client.server.name, ERR_UNKNOWNERROR, "*", "Error assembling message for sending")
- line, _ := message.Line()
-
-- // if we used the trailing hack, we need to strip the final space we appended earlier on
-- if usedTrailingHack {
-- line = line[:len(line)-3] + "\r\n"
-- }
--
- client.socket.Write(line)
- return err
- }
-
-+ // if we used the trailing hack, we need to strip the final space we appended earlier on
-+ if usedTrailingHack {
-+ line = line[:len(line)-3] + "\r\n"
-+ }
-+
- client.server.logger.Debug("useroutput", client.nick, " ->", strings.TrimRight(line, "\r\n"))
-
- client.socket.Write(line)