summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Birks2019-07-13 17:36:06 -0400
committerDavid Birks2019-07-13 17:36:06 -0400
commit04d1c77ebd97fceb1c360217dfa5ea37a4949d22 (patch)
treeae29f9d86834dc3f2cec8ecc7101a287ebcbcb77
downloadaur-04d1c77ebd97fceb1c360217dfa5ea37a4949d22.tar.gz
Initial upload of 0.5.0
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD26
3 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..011f5b2e05e9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = oras
+ pkgdesc = A command line tool that allows you to push and pull files from any OCI registry
+ pkgver = 0.5.0
+ pkgrel = 1
+ url = https://github.com/deislabs/oras
+ arch = x86_64
+ license = MIT
+ makedepends = go
+ source = oras-0.5.0.tar.gz::https://github.com/deislabs/oras/archive/v0.5.0.tar.gz
+ sha512sums = e87ac50027859fbc6e1ca12b14bb4add18d138609649e42bb71eb856e8b1686b692b4daaa37c0fddd210ebb2dcfd815c9c4474a007a3939c4af19174ef773335
+
+pkgname = oras
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..cf9e6049c80e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar.gz
+*.pkg.tar*
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..419bb0082b22
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: David Birks <david@tellus.space>
+
+pkgname=oras
+pkgver=0.5.0
+pkgrel=1
+pkgdesc='A command line tool that allows you to push and pull files from any OCI registry'
+arch=(x86_64)
+url='https://github.com/deislabs/oras'
+license=(MIT)
+makedepends=('go')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/deislabs/oras/archive/v$pkgver.tar.gz")
+sha512sums=('e87ac50027859fbc6e1ca12b14bb4add18d138609649e42bb71eb856e8b1686b692b4daaa37c0fddd210ebb2dcfd815c9c4474a007a3939c4af19174ef773335')
+
+build() {
+ # Flags to trim path from binary
+ export GOFLAGS="-gcflags=all=-trimpath=${PWD} -asmflags=all=-trimpath=${PWD} -ldflags=-extldflags=-zrelro -ldflags=-extldflags=-znow"
+
+ VERSION=$pkgver
+
+ cd $pkgname-$pkgver
+ make build-linux
+}
+
+package() {
+ install -Dm 755 "$srcdir/$pkgname-$pkgver/bin/linux/amd64/$pkgname" "$pkgdir/usr/bin/$pkgname"
+}