summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXuanwo2021-11-26 07:33:38 +0800
committerXuanwo2021-11-26 07:33:38 +0800
commitb4cb91d064f07a4dfb4631db884ee1f93f5dad3a (patch)
tree3f49e2908b0802b3e9bd545fe4cbf7e8efe08b18
parent5f50c44ff164cdf6d5c1c5a65dfebe0821086f82 (diff)
downloadaur-b4cb91d064f07a4dfb4631db884ee1f93f5dad3a.tar.gz
Bump to version 0.12.0
Signed-off-by: Xuanwo <github@xuanwo.io>
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD13
2 files changed, 9 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9abdf795f928..2f01505e52b9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
pkgbase = oras
pkgdesc = A command line tool that allows you to push and pull files from any OCI registry
- pkgver = 0.9.0
+ pkgver = 0.12.0
pkgrel = 1
url = https://github.com/deislabs/oras
arch = x86_64
license = MIT
makedepends = go
makedepends = git
- source = oras-0.9.0.tar.gz::https://github.com/deislabs/oras/archive/v0.9.0.tar.gz
- sha512sums = 2bd3538eb250e41ac2ebd198cb7ca33971a63e7107808a09391ed1b67eae163d9c2f60d2aeef5dcdcd3b9f423820bc00841a5a120b6e0dce018dafadc88e0d6d
+ source = oras-0.12.0.tar.gz::https://github.com/oras-project/oras/archive/v0.12.0.tar.gz
+ sha512sums = 589324805c38f485ecb0122e35984cd6d7b87150c2e67d36bb3ca759750b9ccc9a4803aea9c56c4cbbfb19c914fe7a077d9d091b70b54babc446ac01d3bc2091
pkgname = oras
-
diff --git a/PKGBUILD b/PKGBUILD
index 50a18cec8856..1f958458551d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,14 @@
-# Maintainer: David Birks <david@tellus.space>
-
+# Maintainer: Xuanwo <xuanwo@archlinuxcn.org>
pkgname=oras
-pkgver=0.9.0
+pkgver=0.12.0
pkgrel=1
pkgdesc='A command line tool that allows you to push and pull files from any OCI registry'
arch=(x86_64)
url='https://github.com/deislabs/oras'
license=(MIT)
makedepends=('go' 'git')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/deislabs/oras/archive/v$pkgver.tar.gz")
-sha512sums=('2bd3538eb250e41ac2ebd198cb7ca33971a63e7107808a09391ed1b67eae163d9c2f60d2aeef5dcdcd3b9f423820bc00841a5a120b6e0dce018dafadc88e0d6d')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/oras-project/oras/archive/v$pkgver.tar.gz")
+sha512sums=('589324805c38f485ecb0122e35984cd6d7b87150c2e67d36bb3ca759750b9ccc9a4803aea9c56c4cbbfb19c914fe7a077d9d091b70b54babc446ac01d3bc2091')
build() {
# Flags to trim path from binary
@@ -18,8 +17,8 @@ build() {
export VERSION=$pkgver
cd $pkgname-$pkgver
- GOARCH=amd64 CGO_ENABLED=0 GOOS=linux go build -v \
- -o bin/linux/amd64/oras github.com/deislabs/oras/cmd/oras
+ GOARCH=amd64 CGO_ENABLED=0 GOOS=linux go build \
+ -o bin/linux/amd64/oras github.com/oras-project/oras/cmd/oras
}
package() {