summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-05-14 06:10:10 +0300
committerDimitris Kiziridis2020-05-14 06:10:10 +0300
commitccdabfade27ee73bf42dc3c1ce44e38b8d019605 (patch)
treea5c7407966a59630f51dc177d40b5c74a31a40ea
parent8fcf5f18fa768e5554a23bde8195dbed37e15092 (diff)
downloadaur-ccdabfade27ee73bf42dc3c1ce44e38b8d019605.tar.gz
sanitize pkgbuild
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
2 files changed, 3 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 094edbb9f3eb..ccab1ebad761 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,7 +6,7 @@ pkgbase = orbit-bin
arch = x86_64
license = MIT
provides = orbit
- source = https://github.com/gulien/orbit/releases/download/v3.2.0/orbit_Linux_x86_64.tar.gz
+ source = orbit-bin-3.2.0.tar.gz::https://github.com/gulien/orbit/releases/download/v3.2.0/orbit_Linux_x86_64.tar.gz
sha256sums = bcd0ea0e3cf7858724b5f1863c7e0fc3b04edbd4787497397f1ff8a1a329c663
pkgname = orbit-bin
diff --git a/PKGBUILD b/PKGBUILD
index a86035e65002..df8f7488327a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,11 +8,11 @@ arch=('x86_64')
url='https://github.com/gulien/orbit'
license=('MIT')
provides=('orbit')
-source=("${url}/releases/download/v${pkgver}/orbit_Linux_x86_64.tar.gz")
+source=("${pkgname}-${pkgver}.tar.gz::${url}/releases/download/v${pkgver}/orbit_Linux_x86_64.tar.gz")
sha256sums=('bcd0ea0e3cf7858724b5f1863c7e0fc3b04edbd4787497397f1ff8a1a329c663')
package() {
install -Dm755 "${srcdir}"/orbit "${pkgdir}/usr/bin/orbit"
- install -Dm644 "${srcdir}"/LICENSE "${pkgdir}/usr/share/licenses/orbit/LICENSE"
+ install -Dm644 "${srcdir}"/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
install -Dm644 "${srcdir}"/README.md -t "${pkgdir}/usr/share/doc/orbit"
} \ No newline at end of file