summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMr.Smith19742023-08-02 10:44:39 +0300
committerMr.Smith19742023-08-02 10:44:39 +0300
commit3ce42c27d20f158ac030d038e57a45c53e7ac5d7 (patch)
tree4a2cf82fe8f3e7ef5dca5c841651ad5e0a1ffc66
downloadaur-3ce42c27d20f158ac030d038e57a45c53e7ac5d7.tar.gz
Initial build
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD33
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..45fd65e87ff8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = orbita-sim-git
+ pkgdesc = Simulate and visualize orbits of solar system bodies such as planets, comets and asteroids
+ pkgver = r31.6143899
+ pkgrel = 1
+ url = https://github.com/tstibor/orbita
+ arch = x86_64
+ license = GPL3
+ makedepends = libnova
+ makedepends = qt6-base
+ source = git+https://github.com/tstibor/orbita.git
+ sha256sums = SKIP
+
+pkgname = orbita-sim-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..81c31ccf6a40
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+_pkgname=orbita
+pkgname=orbita-sim-git
+pkgver=r31.6143899
+pkgrel=1
+pkgdesc="Simulate and visualize orbits of solar system bodies such as planets, comets and asteroids"
+arch=(x86_64)
+url="https://github.com/tstibor/orbita"
+license=(GPL3)
+makedepends=('libnova' 'qt6-base')
+source=("git+https://github.com/tstibor/orbita.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd ${_pkgname}
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd ${srcdir}
+ [[ -d build ]] && rm -rf build
+
+ cmake \
+ -S "${_pkgname}" \
+ -B build \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DENABLE_STATIC=NO
+ cmake --build build
+}
+
+package() {
+ cd "${srcdir}/build"
+ DESTDIR="$pkgdir" cmake -P cmake_install.cmake
+}