summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMr.Smith19742023-07-22 10:55:57 +0300
committerMr.Smith19742023-07-22 10:55:57 +0300
commit6d9d3eb64dce6d0909c7e0f01423a44eba7cfda1 (patch)
tree35782670f5528a828291c4f1a68925fcb1f24b26
parent86d5f37ffcd73d067dd4e92832d458f4c2ae3001 (diff)
downloadaur-6d9d3eb64dce6d0909c7e0f01423a44eba7cfda1.tar.gz
Updated build
-rw-r--r--.SRCINFO6
-rw-r--r--Orbiter.desktop11
-rw-r--r--Orbiter_BasicLogo.pngbin0 -> 28709 bytes
-rw-r--r--PKGBUILD27
4 files changed, 37 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 13e44e06ff9d..e09d2129edc7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = orbiter2016-git
pkgdesc = Orbiter Space Flight Simulator
pkgver = r560.01aaeb02
- pkgrel = 1
+ pkgrel = 2
url = http://orbit.medphys.ucl.ac.uk/index.html
arch = x86_64
license = MIT
@@ -12,6 +12,8 @@ pkgbase = orbiter2016-git
makedepends = libsndfile
makedepends = glm
makedepends = texlive-latex
+ source = Orbiter_BasicLogo.png
+ source = Orbiter.desktop
source = TheGondos-orbiter::git+https://github.com/TheGondos/orbiter.git#branch=linux
source = TheGondos-imgui::git+https://github.com/TheGondos/imgui.git
source = TheGondos-XRVessels::git+https://github.com/TheGondos/XRVessels.git
@@ -31,6 +33,8 @@ pkgbase = orbiter2016-git
source = TheGondos-Orb42S::git+https://github.com/TheGondos/Orb42S.git
source = TheGondos-SSRMS::git+https://github.com/TheGondos/SSRMS.git
source = TheGondos-plus42desktop::git+https://github.com/TheGondos/plus42desktop.git
+ sha256sums = 086f1d52d8dfefe71e2f79c3bfd899886ded39a277bb5de78a7aa8f59222ad50
+ sha256sums = c2285249255e7959d99d25d56fa2c97d18db19a4c5549560c1342e536c428821
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
diff --git a/Orbiter.desktop b/Orbiter.desktop
new file mode 100644
index 000000000000..17f13378c2c5
--- /dev/null
+++ b/Orbiter.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Type=Application
+Version=1.0
+Name=Orbiter2016
+Keywords=game;space;
+Icon=Orbiter_BasicLogo
+Exec=Orbiter
+Terminal=false
+StartupNotify=false
+Categories=Game;
+Comment=Orbiter Space Flight Simulator
diff --git a/Orbiter_BasicLogo.png b/Orbiter_BasicLogo.png
new file mode 100644
index 000000000000..94ec1ec8380d
--- /dev/null
+++ b/Orbiter_BasicLogo.png
Binary files differ
diff --git a/PKGBUILD b/PKGBUILD
index 9815a12ccddc..9a53b896cd37 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,10 @@
# Maintainer: Mr.Smith1974
# Contributor: Fabio 'Lolix' Loli <lolix@disroot.org>
+_pkgname=Orbiter
pkgname=orbiter2016-git
pkgver=r560.01aaeb02
-pkgrel=1
+pkgrel=2
pkgdesc="Orbiter Space Flight Simulator"
arch=(x86_64)
url="http://orbit.medphys.ucl.ac.uk/index.html"
@@ -12,7 +13,9 @@ depends=()
makedepends=('git' 'cmake' 'glfw-x11' 'openal' 'libsndfile' 'glm' 'texlive-latex')
provides=()
conflicts=()
-source=("TheGondos-orbiter::git+https://github.com/TheGondos/orbiter.git#branch=linux"
+source=("Orbiter_BasicLogo.png"
+ "Orbiter.desktop"
+ "TheGondos-orbiter::git+https://github.com/TheGondos/orbiter.git#branch=linux"
"TheGondos-imgui::git+https://github.com/TheGondos/imgui.git"
"TheGondos-XRVessels::git+https://github.com/TheGondos/XRVessels.git"
"TheGondos-SOIL2::git+https://github.com/TheGondos/SOIL2.git"
@@ -31,7 +34,9 @@ source=("TheGondos-orbiter::git+https://github.com/TheGondos/orbiter.git#branch=
"TheGondos-Orb42S::git+https://github.com/TheGondos/Orb42S.git"
"TheGondos-SSRMS::git+https://github.com/TheGondos/SSRMS.git"
"TheGondos-plus42desktop::git+https://github.com/TheGondos/plus42desktop.git")
-sha256sums=('SKIP'
+sha256sums=('086f1d52d8dfefe71e2f79c3bfd899886ded39a277bb5de78a7aa8f59222ad50'
+ 'c2285249255e7959d99d25d56fa2c97d18db19a4c5549560c1342e536c428821'
+ 'SKIP'
'SKIP'
'SKIP'
'SKIP'
@@ -85,16 +90,26 @@ prepare() {
}
build() {
+ cd ${srcdir}
+
+ [[ -d build ]] && rm -rf build
+
cmake -B build -S TheGondos-orbiter -Wno-dev \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr
- #can't find Orbitersdk.h at the first run
- cmake --build build || true
cmake --build build
}
package () {
DESTDIR="$pkgdir" cmake --install build
- install -D LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+
+ mkdir -p "$pkgdir/opt/${_pkgname}"
+ mkdir -p "$pkgdir/usr/bin"
+ mkdir -p "$pkgdir/usr/share/applications"
+
+ install -Dm644 "${srcdir}/Orbiter.desktop" "${pkgdir}/usr/share/applications/Orbiter.desktop"
+ install -Dm644 "${srcdir}/Orbiter_BasicLogo.png" "${pkgdir}/usr/share/pixmaps/Orbiter_BasicLogo.png"
+ ln -s "${pkgdir}/usr/Orbiter/Orbiter" "${pkgdir}/usr/bin/Orbiter"
+ install -D "${srcdir}/TheGondos-orbiter/LICENSE" -t "${pkgdir}/usr/share/licenses/${_pkgname}"
}