summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEarnestly2015-08-10 14:42:56 +0100
committerEarnestly2015-08-10 14:43:36 +0100
commit377dfdae1e8a75fbf3a3bca3acab84590fab0ab5 (patch)
tree8f2e99c0c13ddbccb5cd3636b9fd00e25374d756
downloadaur-377dfdae1e8a75fbf3a3bca3acab84590fab0ab5.tar.gz
Add orbment-git
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD59
-rw-r--r--orbment-git.install13
3 files changed, 100 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c5628e7b848c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = orbment-git
+ pkgdesc = A modular wayland compositor based on wlc.
+ pkgver = r388.5252e07
+ pkgrel = 1
+ url = https://github.com/Cloudef/orbment
+ install = orbment-git.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = cmake
+ depends = wlc-git
+ optdepends = weston: To test weston clients in orbment.
+ optdepends = bemenu: Dynamic menu similar to dmenu for launching programs.
+ optdepends = libpng: PNG screenshot compression.
+ provides = orbment
+ conflicts = orbment
+ options = debug
+ options = !strip
+ source = git://github.com/Cloudef/orbment
+ source = git://github.com/Cloudef/chck
+ source = git://github.com/Cloudef/inihck
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = orbment-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2296c109b6f4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,59 @@
+pkgname=orbment-git
+pkgver=r388.5252e07
+pkgrel=1
+
+pkgdesc='A modular wayland compositor based on wlc.'
+url='https://github.com/Cloudef/orbment'
+arch=('i686' 'x86_64')
+license=('GPL')
+
+depends=('wlc-git')
+makedepends=('git' 'cmake')
+optdepends=('weston: To test weston clients in orbment.'
+ 'bemenu: Dynamic menu similar to dmenu for launching programs.'
+ 'libpng: PNG screenshot compression.')
+
+provides=('orbment')
+conflicts=('orbment')
+
+install='orbment-git.install'
+
+source=('git://github.com/Cloudef/orbment'
+ 'git://github.com/Cloudef/chck'
+ 'git://github.com/Cloudef/inihck')
+
+md5sums=('SKIP' 'SKIP' 'SKIP')
+
+# Once this software becomes more stable these requirements will be dropped but
+# for the time being I recommend leaving them enabled so you may contribute
+# useful backtraces to the developer and help remove any errors.
+options=('debug' '!strip')
+
+pkgver() {
+ cd orbment
+ printf 'r%s.%s' "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd orbment
+ git submodule init
+ git config submodule.chck.url "$srcdir"/chck
+ git config submodule.lib/inihck.url "$srcdir"/inihck
+ git submodule update lib/chck/src lib/inihck
+
+ cd lib/inihck
+ git submodule init
+ git config submodule.lib/chck/src.url "$srcdir"/chck
+ git submodule update lib/chck/src
+}
+
+build() {
+ cd orbment
+ cmake -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ cd orbment
+ make DESTDIR="$pkgdir" install
+}
diff --git a/orbment-git.install b/orbment-git.install
new file mode 100644
index 000000000000..0173ff87ce70
--- /dev/null
+++ b/orbment-git.install
@@ -0,0 +1,13 @@
+post_install() {
+ cat <<EOF
+Orbment can optionally take advantage of the logind API for handling sessions
+and devices without requiring root permissions.
+
+If this feature is not wanted you will need to explicitly mark the compositor
+(/usr/bin/orbment) as setuid.
+EOF
+}
+
+post_upgrade() {
+ post_install "$1"
+}