summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2022-08-11 13:59:41 +0200
committerDaniel Peukert2022-08-11 13:59:41 +0200
commit97db5000b30868afeb884f6fbdcaf1e3701e4135 (patch)
tree914fad88a0c4f31b69a961d21a345e7c1de5115e
parent4e507e01176468a02c0194cde2dcf08707806659 (diff)
downloadaur-97db5000b30868afeb884f6fbdcaf1e3701e4135.tar.gz
Fix orbterm build
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD19
-rw-r--r--update-orbfont.diff359
3 files changed, 378 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1efe6a853458..37e1fe99ae84 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = orbterm-git
pkgdesc = The default terminal for RedoxOS, compatible with Linux - git version
- pkgver = 0.3.6.r4.g4ffdd27
- pkgrel = 4
+ pkgver = 0.3.6.r13.gf1ca2c8
+ pkgrel = 1
url = https://gitlab.redox-os.org/redox-os/orbterm
arch = x86_64
arch = i686
@@ -16,6 +16,8 @@ pkgbase = orbterm-git
provides = orbterm
conflicts = orbterm
source = orbterm-git::git+https://gitlab.redox-os.org/redox-os/orbterm
- sha256sums = SKIP
+ source = update-orbfont.diff
+ sha512sums = SKIP
+ sha512sums = 252bfe7afd4aab9e495030894d3bbe904eb4af8946c7869b17bf9a4777d69716cf9220b26d30968ff492ffaed7e5d2cecf25d9e06798ac2639b8cebf73a5cbf2
pkgname = orbterm-git
diff --git a/PKGBUILD b/PKGBUILD
index 2a00ecd7df54..05d7031c94c7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
-# Maintainer: Daniel Peukert <dan.peukert@gmail.com>
+# Maintainer: Daniel Peukert <daniel@peukert.cc>
_pkgname='orbterm'
pkgname="$_pkgname-git"
-pkgver='0.3.6.r4.g4ffdd27'
-pkgrel='4'
+pkgver='0.3.6.r13.gf1ca2c8'
+pkgrel='1'
pkgdesc='The default terminal for RedoxOS, compatible with Linux - git version'
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
url="https://gitlab.redox-os.org/redox-os/$_pkgname"
@@ -11,11 +11,20 @@ depends=('sdl2')
makedepends=('cargo' 'git')
provides=("$_pkgname")
conflicts=("$_pkgname")
-source=("$pkgname::git+$url")
-sha256sums=('SKIP')
+source=(
+ "$pkgname::git+$url"
+ 'update-orbfont.diff'
+)
+sha512sums=('SKIP'
+ '252bfe7afd4aab9e495030894d3bbe904eb4af8946c7869b17bf9a4777d69716cf9220b26d30968ff492ffaed7e5d2cecf25d9e06798ac2639b8cebf73a5cbf2')
_sourcedirectory="$pkgname"
+prepare() {
+ cd "$srcdir/$_sourcedirectory/"
+ patch --forward -p1 < "$srcdir/update-orbfont.diff"
+}
+
pkgver() {
cd "$srcdir/$_sourcedirectory/"
git describe --long --tags | sed -e 's/-\([^-]*-g[^-]*\)$/-r\1/' -e 's/-/./g'
diff --git a/update-orbfont.diff b/update-orbfont.diff
new file mode 100644
index 000000000000..6ba36c977f4f
--- /dev/null
+++ b/update-orbfont.diff
@@ -0,0 +1,359 @@
+diff --git a/Cargo.lock b/Cargo.lock
+index 93e60ff..d52844c 100644
+--- a/Cargo.lock
++++ b/Cargo.lock
+@@ -27,12 +27,12 @@ dependencies = [
+ ]
+
+ [[package]]
+-name = "arrayvec"
+-version = "0.4.12"
++name = "approx"
++version = "0.3.2"
+ source = "registry+https://github.com/rust-lang/crates.io-index"
+-checksum = "cd9fd44efafa8690358b7408d253adf110036b88f55672a933f01d616ad9b1b9"
++checksum = "f0e60b75072ecd4168020818c0107f2857bb6c4e64252d8d3983f6263b40a5c3"
+ dependencies = [
+- "nodrop",
++ "num-traits",
+ ]
+
+ [[package]]
+@@ -43,9 +43,15 @@ checksum = "d9b39be18770d11421cdb1b9947a45dd3f37e93092cbf377614828a319d5fee8"
+ dependencies = [
+ "hermit-abi",
+ "libc",
+- "winapi",
++ "winapi 0.3.9",
+ ]
+
++[[package]]
++name = "autocfg"
++version = "1.1.0"
++source = "registry+https://github.com/rust-lang/crates.io-index"
++checksum = "d468802bab17cbc0cc575e9b053f41e72aa36bfa6b7f55e3529ffa43161b97fa"
++
+ [[package]]
+ name = "backtrace"
+ version = "0.3.66"
+@@ -100,6 +106,46 @@ dependencies = [
+ "cc",
+ ]
+
++[[package]]
++name = "core-foundation"
++version = "0.6.4"
++source = "registry+https://github.com/rust-lang/crates.io-index"
++checksum = "25b9e03f145fd4f2bf705e07b900cd41fc636598fe5dc452fd0db1441c3f496d"
++dependencies = [
++ "core-foundation-sys",
++ "libc",
++]
++
++[[package]]
++name = "core-foundation-sys"
++version = "0.6.2"
++source = "registry+https://github.com/rust-lang/crates.io-index"
++checksum = "e7ca8a5221364ef15ce201e8ed2f609fc312682a8f4e0e3d4aa5879764e0fa3b"
++
++[[package]]
++name = "core-graphics"
++version = "0.14.0"
++source = "registry+https://github.com/rust-lang/crates.io-index"
++checksum = "e54c4ab33705fa1fc8af375bb7929d68e1c1546c1ecef408966d8c3e49a1d84a"
++dependencies = [
++ "bitflags",
++ "core-foundation",
++ "foreign-types",
++ "libc",
++]
++
++[[package]]
++name = "core-text"
++version = "10.0.0"
++source = "registry+https://github.com/rust-lang/crates.io-index"
++checksum = "81f59bff773954e5cd058a3f5983406b52bec7cc65202bef340ba64a0c40ac91"
++dependencies = [
++ "core-foundation",
++ "core-graphics",
++ "foreign-types",
++ "libc",
++]
++
+ [[package]]
+ name = "cty"
+ version = "0.2.2"
+@@ -123,7 +169,7 @@ checksum = "1b1d1d91c932ef41c0f2663aa8b0ca0342d444d842c06914aa0a7e352d0bada6"
+ dependencies = [
+ "libc",
+ "redox_users",
+- "winapi",
++ "winapi 0.3.9",
+ ]
+
+ [[package]]
+@@ -139,6 +185,16 @@ dependencies = [
+ "termcolor",
+ ]
+
++[[package]]
++name = "expat-sys"
++version = "2.1.6"
++source = "registry+https://github.com/rust-lang/crates.io-index"
++checksum = "658f19728920138342f68408b7cf7644d90d4784353d8ebc32e7e8663dbe45fa"
++dependencies = [
++ "cmake",
++ "pkg-config",
++]
++
+ [[package]]
+ name = "failure"
+ version = "0.1.8"
+@@ -161,6 +217,46 @@ dependencies = [
+ "synstructure",
+ ]
+
++[[package]]
++name = "font-loader"
++version = "0.7.0"
++source = "registry+https://github.com/rust-lang/crates.io-index"
++checksum = "fd330f40acb3016432cbfa4c54b3d6e6e893a538df79d8df8fd8c26e21c36aaa"
++dependencies = [
++ "core-foundation",
++ "core-text",
++ "gdi32-sys",
++ "libc",
++ "servo-fontconfig",
++ "user32-sys",
++ "winapi 0.2.8",
++]
++
++[[package]]
++name = "foreign-types"
++version = "0.3.2"
++source = "registry+https://github.com/rust-lang/crates.io-index"
++checksum = "f6f339eb8adc052cd2ca78910fda869aefa38d22d5cb648e6485e4d3fc06f3b1"
++dependencies = [
++ "foreign-types-shared",
++]
++
++[[package]]
++name = "foreign-types-shared"
++version = "0.1.1"
++source = "registry+https://github.com/rust-lang/crates.io-index"
++checksum = "00b0228411908ca8685dba7fc2cdd70ec9990a6e753e89b6ac91a84c40fbaf4b"
++
++[[package]]
++name = "gdi32-sys"
++version = "0.2.0"
++source = "registry+https://github.com/rust-lang/crates.io-index"
++checksum = "0912515a8ff24ba900422ecda800b52f4016a56251922d397c576bf92c690518"
++dependencies = [
++ "winapi 0.2.8",
++ "winapi-build",
++]
++
+ [[package]]
+ name = "getrandom"
+ version = "0.2.7"
+@@ -214,12 +310,6 @@ version = "0.2.126"
+ source = "registry+https://github.com/rust-lang/crates.io-index"
+ checksum = "349d5a591cd28b49e1d1037471617a32ddcda5731b99419008085f72d5a53836"
+
+-[[package]]
+-name = "linked-hash-map"
+-version = "0.5.6"
+-source = "registry+https://github.com/rust-lang/crates.io-index"
+-checksum = "0717cef1bc8b636c6e1c1bbdefc09e6322da8a9321966e8928ef80d20f7f770f"
+-
+ [[package]]
+ name = "log"
+ version = "0.4.17"
+@@ -245,10 +335,13 @@ dependencies = [
+ ]
+
+ [[package]]
+-name = "nodrop"
+-version = "0.1.14"
++name = "num-traits"
++version = "0.2.15"
+ source = "registry+https://github.com/rust-lang/crates.io-index"
+-checksum = "72ef4a56884ca558e5ddb05a1d1e7e1bfd9a68d9ed024c21704cc98872dae1bb"
++checksum = "578ede34cf02f8924ab9447f50c28075b4d3e5b269972345e7e0372b38c6cdcd"
++dependencies = [
++ "autocfg",
++]
+
+ [[package]]
+ name = "object"
+@@ -282,12 +375,12 @@ dependencies = [
+
+ [[package]]
+ name = "orbfont"
+-version = "0.1.8"
+-source = "registry+https://github.com/rust-lang/crates.io-index"
+-checksum = "da4dfbc851e5c24c3cf1e16ec5222f868f3362d2b7493d0b53051fe2669267a2"
++version = "0.1.9"
++source = "git+https://gitlab.redox-os.org/redox-os/orbfont?rev=1e971348#1e971348460520015867740795a4dca249750c30"
+ dependencies = [
++ "font-loader",
+ "orbclient",
+- "rusttype",
++ "rusttype 0.7.9",
+ ]
+
+ [[package]]
+@@ -308,6 +401,21 @@ dependencies = [
+ "xdg",
+ ]
+
++[[package]]
++name = "ordered-float"
++version = "1.1.1"
++source = "registry+https://github.com/rust-lang/crates.io-index"
++checksum = "3305af35278dd29f46fcdd139e0b1fbfae2153f0e5928b39b035542dd31e37b7"
++dependencies = [
++ "num-traits",
++]
++
++[[package]]
++name = "pkg-config"
++version = "0.3.25"
++source = "registry+https://github.com/rust-lang/crates.io-index"
++checksum = "1df8c4ec4b0627e53bdf214615ad287367e482558cf84b109250b37464dc03ae"
++
+ [[package]]
+ name = "proc-macro2"
+ version = "1.0.42"
+@@ -409,13 +517,22 @@ checksum = "7ef03e0a2b150c7a90d01faf6254c9c48a41e95fb2a8c2ac1c6f0d2b9aefc342"
+
+ [[package]]
+ name = "rusttype"
+-version = "0.2.4"
++version = "0.7.9"
++source = "registry+https://github.com/rust-lang/crates.io-index"
++checksum = "310942406a39981bed7e12b09182a221a29e0990f3e7e0c971f131922ed135d5"
++dependencies = [
++ "rusttype 0.8.3",
++]
++
++[[package]]
++name = "rusttype"
++version = "0.8.3"
+ source = "registry+https://github.com/rust-lang/crates.io-index"
+-checksum = "d8d729e72445ad579171b01a9231657736b3793a2cf423078e687e20ecb8695a"
++checksum = "9f61411055101f7b60ecf1041d87fb74205fb20b0c7a723f07ef39174cf6b4c0"
+ dependencies = [
+- "arrayvec",
+- "linked-hash-map",
+- "stb_truetype 0.2.8",
++ "approx",
++ "ordered-float",
++ "stb_truetype",
+ ]
+
+ [[package]]
+@@ -461,12 +578,34 @@ dependencies = [
+ ]
+
+ [[package]]
+-name = "stb_truetype"
+-version = "0.2.8"
++name = "servo-fontconfig"
++version = "0.4.0"
++source = "registry+https://github.com/rust-lang/crates.io-index"
++checksum = "a088f8d775a5c5314aae09bd77340bc9c67d72b9a45258be34c83548b4814cd9"
++dependencies = [
++ "libc",
++ "servo-fontconfig-sys",
++]
++
++[[package]]
++name = "servo-fontconfig-sys"
++version = "4.0.9"
+ source = "registry+https://github.com/rust-lang/crates.io-index"
+-checksum = "9d1bec4382294c5a680fcebd29f8451e8d8c04479a026f6909004e2ab1cb425d"
++checksum = "62b3e166450f523f4db06c14f02a2d39e76d49b5d8cbd224338d93e3595c156c"
+ dependencies = [
+- "stb_truetype 0.3.1",
++ "expat-sys",
++ "pkg-config",
++ "servo-freetype-sys",
++]
++
++[[package]]
++name = "servo-freetype-sys"
++version = "4.0.5"
++source = "registry+https://github.com/rust-lang/crates.io-index"
++checksum = "2c4ccb6d0d32d277d3ef7dea86203d8210945eb7a45fba89dd445b3595dd0dfc"
++dependencies = [
++ "cmake",
++ "pkg-config",
+ ]
+
+ [[package]]
+@@ -551,6 +690,16 @@ version = "0.2.3"
+ source = "registry+https://github.com/rust-lang/crates.io-index"
+ checksum = "957e51f3646910546462e67d5f7599b9e4fb8acdd304b087a6494730f9eebf04"
+
++[[package]]
++name = "user32-sys"
++version = "0.2.0"
++source = "registry+https://github.com/rust-lang/crates.io-index"
++checksum = "4ef4711d107b21b410a3a974b1204d9accc8b10dad75d8324b5d755de1617d47"
++dependencies = [
++ "winapi 0.2.8",
++ "winapi-build",
++]
++
+ [[package]]
+ name = "utf8parse"
+ version = "0.1.1"
+@@ -642,6 +791,12 @@ dependencies = [
+ "wasm-bindgen",
+ ]
+
++[[package]]
++name = "winapi"
++version = "0.2.8"
++source = "registry+https://github.com/rust-lang/crates.io-index"
++checksum = "167dc9d6949a9b857f3451275e911c3f44255842c1f7a76f33c55103a909087a"
++
+ [[package]]
+ name = "winapi"
+ version = "0.3.9"
+@@ -652,6 +807,12 @@ dependencies = [
+ "winapi-x86_64-pc-windows-gnu",
+ ]
+
++[[package]]
++name = "winapi-build"
++version = "0.1.1"
++source = "registry+https://github.com/rust-lang/crates.io-index"
++checksum = "2d315eee3b34aca4797b2da6b13ed88266e6d612562a0c46390af8299fc699bc"
++
+ [[package]]
+ name = "winapi-i686-pc-windows-gnu"
+ version = "0.4.0"
+@@ -664,7 +825,7 @@ version = "0.1.5"
+ source = "registry+https://github.com/rust-lang/crates.io-index"
+ checksum = "70ec6ce85bb158151cae5e5c87f95a8e97d2c0c4b001223f33a334e3ce5de178"
+ dependencies = [
+- "winapi",
++ "winapi 0.3.9",
+ ]
+
+ [[package]]
+diff --git a/Cargo.toml b/Cargo.toml
+index 7763f0b..e63b14a 100644
+--- a/Cargo.toml
++++ b/Cargo.toml
+@@ -15,7 +15,7 @@ path = "src/main.rs"
+ env_logger = { version = "0.8", optional = true }
+ failure = "0.1.5"
+ orbclient = "0.3.24"
+-orbfont = "0.1.8"
++orbfont = { git = "https://gitlab.redox-os.org/redox-os/orbfont", rev = "1e971348" }
+ ransid = "0.4.7"
+ serde = "1.0.94"
+ serde_derive = "1.0.94"