summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTomasz Żok2016-11-03 14:29:28 +0100
committerTomasz Żok2016-11-03 14:29:28 +0100
commit35452cb8eddce5fac67d390c4eba076b201c5709 (patch)
tree53674092c8a5dbde8a53d949e5a30fd5da4f24ea
downloadaur-35452cb8eddce5fac67d390c4eba076b201c5709.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD21
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1e442bd6ffb8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = orchent
+ pkgdesc = Orchestrator Command Line Client
+ pkgver = 0.2.0
+ pkgrel = 1
+ url = https://github.com/indigo-dc/orchent
+ arch = x86
+ arch = x86_64
+ license = Apache
+ makedepends = go>=1.5
+ source = https://github.com/indigo-dc/orchent/archive/v0.2.0.tar.gz
+ md5sums = c6ee304e51e5efc6afefad218f2af1b4
+
+pkgname = orchent
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..20e4e437827a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Tomasz Zok <tomasz.zok [at] gmail.com>
+pkgname=orchent
+pkgver=0.2.0
+pkgrel=1
+pkgdesc="Orchestrator Command Line Client"
+arch=(x86 x86_64)
+url="https://github.com/indigo-dc/orchent"
+license=('Apache')
+depends=('go>=1.5')
+source=(https://github.com/indigo-dc/$pkgname/archive/v$pkgver.tar.gz)
+md5sums=('c6ee304e51e5efc6afefad218f2af1b4')
+
+build() {
+ cd "$pkgname-$pkgver"
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -D ${pkgname} ${pkgdir}/usr/bin/${pkgname}
+}