summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArgyros Argyridis2017-10-29 13:15:13 +0200
committerArgyros Argyridis2017-10-29 13:15:13 +0200
commit8fa3ba15fa640ede552f597839a8c213a6dfa19d (patch)
treeda2494c2becba4ab609180b1ba2d7602ce76cb66
parentd12355082e414ba251ff3952a93b4c26cfdffc71 (diff)
downloadaur-8fa3ba15fa640ede552f597839a8c213a6dfa19d.tar.gz
updated to 6.2.0-RC1
-rw-r--r--.SRCINFO10
-rwxr-xr-xPKGBUILD26
2 files changed, 17 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 31ba864bc21e..0e710573c2e8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = orfeo-toolbox
pkgdesc = ORFEO Toolbox (OTB) is an open source library of image processing algorithms
- pkgver = 6.0.0
+ pkgver = 6.2.0
pkgrel = 1
url = http://www.orfeo-toolbox.org/otb/
arch = x86_64
@@ -25,10 +25,12 @@ pkgbase = orfeo-toolbox
depends = ossim
depends = libsvm
depends = mapnik
- depends = qwt5
- source = https://www.orfeo-toolbox.org/packages/OTB-6.0.0.tar.gz
+ depends = qwt
+ depends = opencv
+ depends = mapnik
+ source = https://www.orfeo-toolbox.org/packages/OTB-6.2.0.tar.gz
source = git://github.com/jmichel-otb/GKSVM.git
- md5sums = a327179e973eb21462d7db24f98f24fd
+ md5sums = 39a28866b924edcb7d7a900cc5df31f3
md5sums = SKIP
pkgname = orfeo-toolbox
diff --git a/PKGBUILD b/PKGBUILD
index 1c649a07b072..ce3b74b86e69 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,9 +2,9 @@
# Contributor: Samuel Mesa <samuelmesa@linuxmail.org>
pkgname=orfeo-toolbox
-pkgver=6.0.0
-_pkgver=6.0
-minorver=1
+pkgver=6.2.0
+_pkgver=6.2
+minorver=0
pkgrel=1
pkgdesc="ORFEO Toolbox (OTB) is an open source library of image processing algorithms"
arch=(x86_64 i686)
@@ -12,7 +12,7 @@ url="http://www.orfeo-toolbox.org/otb/"
license=('CeCILL')
groups=()
depends=('cmake' 'gdal' 'agg' 'freeglut' 'curl' 'fftw' 'tinyxml' 'muparser' 'fltk' 'python2' 'openthreads'
- 'hdf5' 'insight-toolkit' 'libkml' 'ossim' 'libsvm' 'mapnik' 'qwt5')
+ 'hdf5' 'insight-toolkit' 'libkml' 'ossim' 'libsvm' 'mapnik' 'qwt' 'opencv' 'mapnik')
makedepends=('boost' 'swig')
optdepends=()
provides=()
@@ -27,7 +27,7 @@ source=(https://www.orfeo-toolbox.org/packages/OTB-$pkgver.tar.gz
git://github.com/jmichel-otb/GKSVM.git)
noextract=()
-md5sums=('a327179e973eb21462d7db24f98f24fd'
+md5sums=('39a28866b924edcb7d7a900cc5df31f3'
'SKIP')
@@ -47,11 +47,12 @@ build() {
if [ -d "$srcdir/build/" ]; then
rm -rf $srcdir/build/
fi
+
mkdir $srcdir/build/
-cd $srcdir/build
+ cd $srcdir/build
-cmake ../OTB-release-$_pkgver \
+ cmake ../OTB-release-$_pkgver \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_CXX_FLAGS="$CXXFLAGS -fPIC" \
-DCMAKE_C_FLAGS="$CFLAGS -fPIC" \
@@ -64,11 +65,10 @@ cmake ../OTB-release-$_pkgver \
-DPYTHON_LIBRARIES=/usr/lib/libpython2.7.so \
-DPYTHON_INCLUDE_PATH=/usr/include/python2.7/ \
-DOTB_INSTALL_PYTHON_DIR=/usr/lib/python2.7/site-packages/ \
--DITK_DIR=/usr/lib64/cmake/ITK-4.10 \
-DBUILD_SHARED_LIBS=ON \
-DOTB_USE_QT4=ON \
--DOTB_USE_MAPNIK=OFF \
--DOTB_USE_OPENCV=OFF \
+-DOTB_USE_MAPNIK=ON \
+-DOTB_USE_OPENCV=ON \
-DOTB_USE_MUPARSER=ON \
-DOTB_USE_LIBKML=ON \
-DOTB_USE_LIBSVM=ON \
@@ -78,12 +78,8 @@ cmake ../OTB-release-$_pkgver \
-DOTB_BUILD_ALL_MODULES_FOR_TESTS=ON \
-DOTB_USE_GLEW=ON \
-DOTB_USE_QWT=ON \
--DQWT_INCLUDE_DIR=/usr/include/qwt5 \
--DQWT_LIBRARY=/usr/lib64/libqwt5.so
-
-make
-
+make
}
package() {