summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxywei2020-07-19 15:49:15 -0500
committerxywei2020-07-19 15:49:15 -0500
commitdd57e3d5db18993aca59052e93e6f4e87a662ccc (patch)
tree4d79842a8397827adb2f8db15aec53a30aa7551f
parent3e07ac072bff2dab369393cc393c80ae7c1684b0 (diff)
downloadaur-dd57e3d5db18993aca59052e93e6f4e87a662ccc.tar.gz
Update PKGBUILD
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD33
2 files changed, 22 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3d566ecf2713..669c045bbed2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = orgmk-git
pkgdesc = Export Org mode documents to HTML, PDF, etc.
- pkgver = r45.42ceb56
- pkgrel = 2
+ pkgver = r77.2fa2bde
+ pkgrel = 1
url = https://github.com/fniessen/orgmk
arch = any
license = GPL
diff --git a/PKGBUILD b/PKGBUILD
index f8c1e0dd8342..ba1edacb4a4f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,10 @@
-# Maintainer: csllbr
+# Maintainer: xywei <wxy0516@gmail.com>
+# Contributor: csllbr
_pkgname=orgmk
pkgname=orgmk-git
-pkgver=r45.42ceb56
-pkgrel=2
+pkgver=r77.2fa2bde
+pkgrel=1
pkgdesc='Export Org mode documents to HTML, PDF, etc.'
url='https://github.com/fniessen/orgmk'
license=('GPL')
@@ -12,7 +13,6 @@ sha256sums=('SKIP')
arch=('any')
depends=('emacs')
makedepends=('git')
-conflicts=('')
provides=('orgmk')
pkgver() {
@@ -24,18 +24,25 @@ pkgver() {
build() {
cd "${srcdir}/${_pkgname}"
- sed -i '/ORGMK_ROOT=\$\(PWD\)/c\ORGMK_ROOT=/usr/share/orgmk' Makefile
- make
+
+ # Fix PWD for sources of symlinks, made portable with relative paths
+ sed -i '/PWD=\$(shell\ pwd)/c\PWD=..\/share\/orgmk' Makefile
+
+ # Fix ORGMK_ROOT which gets hard-coded into emacs-lisp scripts
+ sed -i '/ORGMK_ROOT=\$(PWD)/c\ORGMK_ROOT=\/usr\/share\/orgmk' Makefile
+
+ # Fix BIN_DIR for destinations of symlinks
+ sed -i '/BIN_DIR=\/usr\/local\/bin/c\BIN_DIR=\${DESTDIR}\/usr\/bin' Makefile
}
package() {
- mkdir -p "${pkgdir}"/usr/share/orgmk
- mkdir -p "${pkgdir}"/usr/bin
- cd "${srcdir}"
+ mkdir -p "${pkgdir}"/usr/share/orgmk/
+ mkdir -p "${pkgdir}"/usr/bin/
+ cp -r "${srcdir}/${_pkgname}"/* "${pkgdir}"/usr/share/orgmk/
- cp -R ${_pkgname}/* "${pkgdir}"/usr/share/orgmk
+ cd "${pkgdir}"/usr/share/orgmk
- ln -s /usr/share/orgmk/bin/* "${pkgdir}"/usr/bin
-
-} \ No newline at end of file
+ make DESTDIR="${pkgdir}"
+ make DESTDIR="${pkgdir}" install
+}