summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJeff Henson2019-01-12 11:28:02 -0700
committerJeff Henson2019-01-12 11:28:02 -0700
commit72d0c914483ff467d9f10916a0debfb25dc99919 (patch)
tree857cd3f2a1c68561efbe09c7b98fa0c9bd98e52d
downloadaur-72d0c914483ff467d9f10916a0debfb25dc99919.tar.gz
Intial commit for v3.11.0
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD26
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4b1177611a10
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = origin-client
+ pkgdesc = Openshift client binary
+ pkgver = 3.11.0
+ pkgrel = 1
+ url = https://github.com/openshift/origin
+ arch = x86_64
+ license = Apache
+ makedepends = go
+ makedepends = rsync
+ source = git+https://github.com/openshift/origin#tag=v3.11.0?signed
+ validpgpkeys = 0E2CFB1B72F087ACF089B41E3D16906B4F1C5CB3
+ sha256sums = SKIP
+
+pkgname = origin-client
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0e20df603914
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+pkgname=origin-client
+pkgdesc="Openshift client binary"
+pkgver=3.11.0
+pkgrel=1
+arch=('x86_64')
+url="https://github.com/openshift/origin"
+license=('Apache')
+makedepends=('go' 'rsync')
+validpgpkeys=('0E2CFB1B72F087ACF089B41E3D16906B4F1C5CB3') # Clayton Coleman (Red Hat key) <ccoleman@redhat.com>
+source=("git+https://github.com/openshift/origin#tag=v${pkgver}?signed")
+sha256sums=('SKIP')
+
+build() {
+ cd "${srcdir}/origin"
+ make WHAT=cmd/oc
+ hack/generate-docs.sh
+}
+
+package() {
+ cd "${srcdir}/origin"
+ install -Dm755 _output/local/bin/linux/amd64/oc -t "$pkgdir/usr/bin"
+ install -Dm644 docs/man/man1/* -t "$pkgdir/usr/share/man/man1"
+
+ "$pkgdir/usr/bin/oc" completion bash | install -Dm644 /dev/stdin "$pkgdir/usr/share/bash-completion/completions/oc"
+ "$pkgdir/usr/bin/oc" completion zsh | install -Dm644 /dev/stdin "$pkgdir/usr/share/zsh/site-functions/_oc"
+}