summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM0Rf302022-01-08 00:08:18 +0100
committerGianluca Boiano2022-01-08 00:08:18 +0100
commita2ba01fa5af15cee305881068ccaf33736d829b9 (patch)
tree09766dd7d8687de3dd7baf030a2785ad5d763593
downloadaur-a2ba01fa5af15cee305881068ccaf33736d829b9.tar.gz
orion-desktop: 0.0.10
-rw-r--r--.SRCINFO67
-rw-r--r--PKGBUILD93
-rw-r--r--orion-desktop.desktop14
-rw-r--r--orion-desktop.sh2
-rwxr-xr-xsnap-dlagent.sh8
5 files changed, 184 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3bf33db2c2c7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,67 @@
+pkgbase = orion-desktop
+ pkgdesc = A powerful, lightweight, fast BitTorrent client, with beautiful user experience and fastest video and audio streaming capabilities
+ pkgver = 0.0.10
+ pkgrel = 1
+ url = https://snapcraft.io/orion-desktop
+ arch = x86_64
+ license = PROPRIETARY
+ makedepends = squashfs-tools
+ depends = brotli
+ depends = bzip2
+ depends = double-conversion
+ depends = e2fsprogs
+ depends = freetype2
+ depends = gcc-libs
+ depends = glib2
+ depends = glibc
+ depends = graphite
+ depends = gst-plugins-base-libs
+ depends = gstreamer
+ depends = harfbuzz
+ depends = hyphen
+ depends = icu
+ depends = keyutils
+ depends = krb5
+ depends = libcap
+ depends = libelf
+ depends = libffi
+ depends = libgcrypt
+ depends = libglvnd
+ depends = libgpg-error
+ depends = libjpeg-turbo
+ depends = libpng
+ depends = libunwind
+ depends = libwebp
+ depends = libxau
+ depends = libxcb
+ depends = libxdmcp
+ depends = libxml2
+ depends = libxslt
+ depends = lz4
+ depends = md4c
+ depends = openssl
+ depends = orc
+ depends = pcre
+ depends = pcre2
+ depends = qt5-base
+ depends = qt5-declarative
+ depends = qt5-location
+ depends = qt5-sensors
+ depends = qt5-webchannel
+ depends = qt5-webkit
+ depends = sqlite
+ depends = woff2
+ depends = xz
+ depends = zlib
+ depends = zstd
+ options = !strip
+ source = orion-desktop-0.0.10.squashfs::snap://api.snapcraft.io/v2/snaps/info/orion-desktop
+ source = snap-dlagent.sh
+ source = orion-desktop.desktop
+ source = orion-desktop.sh
+ sha256sums = fe8c4be513d2d88a07cdc4c7d073adf84a1a2b25c25ea8c12010456006ff1cca
+ sha256sums = 25f7ceaaec37eb9c287abeb839ba2036738eb363079e321c2bd410fa48301dd6
+ sha256sums = 71420954985d07f63c8195d5e6ff12c55ac366d99fd3024846bbdc8463af2579
+ sha256sums = 4991a25e728da947d59c31d9a790f2edaf04ae073bd267ea2ffcf519fe12f274
+
+pkgname = orion-desktop
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5f970f48be47
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,93 @@
+# Maintainer: robertfoster
+
+pkgname=orion-desktop
+pkgver=0.0.10
+pkgrel=1
+pkgdesc="A powerful, lightweight, fast BitTorrent client, with beautiful user experience and fastest video and audio streaming capabilities"
+arch=('x86_64')
+url="https://snapcraft.io/orion-desktop"
+license=('PROPRIETARY')
+options=('!strip')
+depends=(
+ 'brotli'
+ 'bzip2'
+ 'double-conversion'
+ 'e2fsprogs'
+ 'freetype2'
+ 'gcc-libs'
+ 'glib2'
+ 'glibc'
+ 'graphite'
+ 'gst-plugins-base-libs'
+ 'gstreamer'
+ 'harfbuzz'
+ 'hyphen'
+ 'icu'
+ 'keyutils'
+ 'krb5'
+ 'libcap'
+ 'libelf'
+ 'libffi'
+ 'libgcrypt'
+ 'libglvnd'
+ 'libgpg-error'
+ 'libjpeg-turbo'
+ 'libpng'
+ 'libunwind'
+ 'libwebp'
+ 'libxau'
+ 'libxcb'
+ 'libxdmcp'
+ 'libxml2'
+ 'libxslt'
+ 'lz4'
+ 'md4c'
+ 'openssl'
+ 'orc'
+ 'pcre'
+ 'pcre2'
+ 'qt5-base'
+ 'qt5-declarative'
+ 'qt5-location'
+ 'qt5-sensors'
+ 'qt5-webchannel'
+ 'qt5-webkit'
+ 'sqlite'
+ 'woff2'
+ 'xz'
+ 'zlib'
+ 'zstd'
+)
+
+makedepends=('squashfs-tools')
+sha256sums=('fe8c4be513d2d88a07cdc4c7d073adf84a1a2b25c25ea8c12010456006ff1cca'
+ '25f7ceaaec37eb9c287abeb839ba2036738eb363079e321c2bd410fa48301dd6'
+ '71420954985d07f63c8195d5e6ff12c55ac366d99fd3024846bbdc8463af2579'
+ '4991a25e728da947d59c31d9a790f2edaf04ae073bd267ea2ffcf519fe12f274')
+
+DLAGENTS+=("snap::${BASH_SOURCE[0]%/*}/snap-dlagent.sh %u %o")
+source=("${pkgname}-${pkgver}.squashfs::snap://api.snapcraft.io/v2/snaps/info/orion-desktop"
+ snap-dlagent.sh
+ "${pkgname}.desktop"
+ "${pkgname}.sh"
+)
+
+prepare() {
+ cd "${srcdir}"
+
+ msg2 "Extraction..."
+ unsquashfs ${pkgname}-${pkgver}.squashfs
+}
+
+package() {
+ cd "${srcdir}"
+
+ mkdir -p "${pkgdir}/opt/"
+ cp -r squashfs-root "${pkgdir}/opt/${pkgname}"
+ install -Dm755 orion-desktop.sh \
+ "${pkgdir}/usr/bin/${pkgname}"
+ install -Dm644 squashfs-root/meta/gui/icon.png \
+ "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
+ install -Dm644 "${pkgname}.desktop" \
+ "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+}
diff --git a/orion-desktop.desktop b/orion-desktop.desktop
new file mode 100644
index 000000000000..86ac495a7de1
--- /dev/null
+++ b/orion-desktop.desktop
@@ -0,0 +1,14 @@
+[Desktop Entry]
+Version=1.0
+GenericName=BitTorrent client & Streamer
+Name[en_US]=Orion
+Comment=Download Discover and share files over BitTorrent
+MimeType=application/x-bittorrent;x-scheme-handler/magnet;
+Name=Orion
+Type=Application
+Icon=orion-desktop
+Keywords=bittorrent;stream;torrent;magnet;download;p2p
+Exec=orion-desktop %F
+Categories=Network;FileTransfer;P2P;Qt;
+Terminal=false
+StartupNotify=false
diff --git a/orion-desktop.sh b/orion-desktop.sh
new file mode 100644
index 000000000000..aff0f3f0110e
--- /dev/null
+++ b/orion-desktop.sh
@@ -0,0 +1,2 @@
+#!/bin/bash
+exec /opt/orion-desktop/usr/bin/orion
diff --git a/snap-dlagent.sh b/snap-dlagent.sh
new file mode 100755
index 000000000000..0c67c53e138e
--- /dev/null
+++ b/snap-dlagent.sh
@@ -0,0 +1,8 @@
+# An script to download from ModDB
+url="${1}"
+output="${2}"
+resolved_url=$(curl -H 'Snap-Device-Series: 16' https://${url#snap://} | jq '."channel-map"' | jq '.[]' | jq '[."download"."url"]' | grep -m1 https | tr -d ' ' | tr -d '"')
+
+echo "Downloading ${output}"
+curl -L -C - "${resolved_url}" -o \
+ "${output}"