summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoramesgen2020-01-13 05:33:30 +0100
committeramesgen2020-01-13 05:33:30 +0100
commit8e28c448e528b144cad6bab20da658b1d6ffc109 (patch)
treef412a69940d85c34f8db3096e41b15a2cdaffe2e
downloadaur-8e28c448e528b144cad6bab20da658b1d6ffc109.tar.gz
created package
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD29
-rw-r--r--stack.yaml3
3 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..390c2d590ca2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ormolu
+ pkgdesc = A formatter for Haskell source code
+ pkgver = 0.0.3.0
+ pkgrel = 1
+ url = https://github.com/tweag/ormolu
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = stack
+ source = https://github.com/tweag/ormolu/archive/0.0.3.0.tar.gz
+ source = stack.yaml
+ sha256sums = 59eccef466353f85ab40cd76c1dd5a7e87598e27c7db798a741c5c8aba1d635b
+ sha256sums = b924a2de0804fefa9b513cd7e790fb41e0b178742ee7e78c82e3ae64deb26a76
+
+pkgname = ormolu
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a907279c42fa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: amesgen <amesgen AT amesgen DOT de>
+
+pkgname=ormolu
+pkgver=0.0.3.0
+pkgrel=1
+pkgdesc="A formatter for Haskell source code"
+arch=('i686' 'x86_64')
+url="https://github.com/tweag/${pkgname}"
+license=('custom')
+makedepends=('stack')
+source=("${url}/archive/${pkgver}.tar.gz"
+ 'stack.yaml')
+sha256sums=('59eccef466353f85ab40cd76c1dd5a7e87598e27c7db798a741c5c8aba1d635b'
+ 'b924a2de0804fefa9b513cd7e790fb41e0b178742ee7e78c82e3ae64deb26a76')
+
+prepare() {
+ mv stack.yaml "${pkgname}-${pkgver}/"
+}
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ stack build
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ stack install --local-bin-path "${pkgdir}/usr/bin"
+ install -Dm644 LICENSE.md "$pkgdir/usr/share/licenses/$pkgname/LICENSE.md"
+}
diff --git a/stack.yaml b/stack.yaml
new file mode 100644
index 000000000000..15e173b333d1
--- /dev/null
+++ b/stack.yaml
@@ -0,0 +1,3 @@
+resolver: lts-14.20
+extra-deps:
+- ghc-lib-parser-8.8.1