summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoramesgen2021-09-15 13:54:55 +0200
committeramesgen2021-09-15 13:54:55 +0200
commitea40f548a2ad7db8a140de72514e2d8349024de2 (patch)
tree8e52334fc4cea88dc7af8275e2f7fc0d6d058605
downloadaur-ea40f548a2ad7db8a140de72514e2d8349024de2.tar.gz
Initial commit, using Ormolu 0.3.0.0
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD29
3 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..58c37a5fcef8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ormolu-bin
+ pkgdesc = A formatter for Haskell source code
+ pkgver = 0.3.0.0
+ pkgrel = 1
+ url = https://github.com/tweag/ormolu
+ arch = x86_64
+ license = BSD
+ provides = ormolu
+ conflicts = ormolu
+ conflicts = haskell-ormolu
+ source = ormolu-0.3.0.0.zip::https://github.com/tweag/ormolu/releases/download/0.3.0.0/ormolu-Linux.zip
+ source = LICENSE-0.3.0.0::https://raw.githubusercontent.com/tweag/ormolu/0.3.0.0/LICENSE.md
+ sha256sums = 16a5de3482c786c1001cda90527aa7976f0ebdefcd788ef8681bbff652791731
+ sha256sums = 6572a825b43b87cf53d197723e1d64ce78535fe8bfa19b1377be582909b81141
+
+pkgname = ormolu-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72e8ffc0db8a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ef779efdc79f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: amesgen <amesgen AT amesgen DOT de>
+
+pkgname='ormolu-bin'
+pkgver=0.3.0.0
+pkgrel=1
+pkgdesc="A formatter for Haskell source code"
+arch=('x86_64')
+url='https://github.com/tweag/ormolu'
+license=('BSD')
+provides=('ormolu')
+conflicts=('ormolu' 'haskell-ormolu')
+
+source=("ormolu-$pkgver.zip::https://github.com/tweag/ormolu/releases/download/$pkgver/ormolu-Linux.zip"
+ "LICENSE-$pkgver::https://raw.githubusercontent.com/tweag/ormolu/$pkgver/LICENSE.md")
+sha256sums=('16a5de3482c786c1001cda90527aa7976f0ebdefcd788ef8681bbff652791731'
+ '6572a825b43b87cf53d197723e1d64ce78535fe8bfa19b1377be582909b81141')
+
+package() {
+ install -Dm644 LICENSE-$pkgver "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+
+ install -Dm755 "$srcdir/ormolu" -t "$pkgdir/usr/bin/"
+ _install_completion_script bash bash-completion/completions/ormolu
+ _install_completion_script zsh zsh/site-functions/_ormolu
+ _install_completion_script fish fish/vendor_completions.d/ormolu.fish
+}
+
+_install_completion_script() {
+ install -Dm644 <("$pkgdir/usr/bin/ormolu" --$1-completion-script /usr/bin/ormolu) "$pkgdir/usr/share/$2"
+}