summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgesh2024-09-03 22:04:43 +0300
committergesh2025-01-23 16:48:16 +0200
commite6825d107efc4d4762633ffbad32c970e6670d14 (patch)
treed8d64e4e929371a26f181fb0d2cbec1823cf9f58
parentbfbd1468c09a451845892922d11cfd2e1cc6954b (diff)
downloadaur-e6825d107efc4d4762633ffbad32c970e6670d14.tar.gz
Bump to LTS 23.1
Upstream raised minimal version of `base`, forcing moving to GHC 9.8.4
-rw-r--r--PKGBUILD17
1 files changed, 11 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ced65babf67b..8794c043e4e3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -44,13 +44,18 @@ pkgver() {
prepare() {
cd "$pkgname"
- stack config set resolver lts-22.22 # ghc-9.6.5
+ stack config set resolver lts-23.1 # ghc-9.8.4
- _bumpVer aeson 2.2.2.0
- _bumpVer character-ps 0.1
- _bumpVer parsec 3.1.17.0
- _bumpVer text 2.1.1
- _bumpVer text-iso8601 0.1.1
+ _bumpVer directory 1.3.9.0
+ _bumpVer filepath 1.5.4.0
+ _bumpVer process 1.6.25.0
+ _bumpVer unix 2.8.6.0
+
+ yq -i --yaml-output \
+ '(.flags |
+ (.unix, .directory, ."file-io") |
+ ."os-string")
+ = true' stack.yaml
# enable tests
yq -i --yaml-output \